Jump to content

Poroner

Members
  • Content count

    10
  • Joined

  • Last visited

  • Days Won

    1

Poroner last won the day on December 11 2016

Poroner had the most liked content!

Community Reputation

3 Fine

About Poroner

  • Rank
    Indium Shaman

Previous Fields

  • Favorite pizza topping
    Cheese
  • Why do you want to join DarkMatters?
    Community Patch for sacred 2 and help
  • Real Name
    Thanasis
  • Platform
    PC
  • PSN ID
    Poroner
  • Steam Name
    Poroner
  • Country
    Greece

Profile Information

  • Gender
    Male
  • Location
    GR
  1. Will do for sure once I'm sure it actually works.
  2. Perhaps but I tried all three regardless and no crashes so far! I must have around 4 or so hours of gameplay with a new character and the game is smooth as butter. Now, all the other times I tried to play it took a while before the crashes started happening but this is a good sign. I've also been monitoring RAM usage and no leaks there. It probably is the patch that fixed it but I'm scared of turning on physx regardless in the off case it screws something up and then physx on or off it keeps crashing again (like my options menu kept crashing for no reason at some point even after a reinstall lol...) and music I don't really care for so much. I just listen to other things when I play this game anyway. Not playing that much now but when I hit around 15 hours of gameplay I'll be sure if the issue is fixed or not but anyway, this seriously made my week. Thank you all for your help.
  3. So I'll try a combination of the fixes here. I was looking for something to play again and bam this thread pops up! I'll install the beta CM patch, lower the volume slider and play with physx off. I don't want to keep restarting the game because the crashes happen every 1-2 hours. Another thing, there was another game I played that the GOG version worked perfectly while the steam one had problems. What they did is get the .exe from the gog game directory and replace the steam one with it (Basically cracking) and the game worked perfectly. It wouldn't hurt sharing the gog .exe.
  4. I'd rather not risk it and I don't feel like paying again for a game I payed outside of a sale for. Besides as soon as I get my hand on an empty disk or a usb I'll install xp. Yeah yeah I know, I don't have any right now
  5. I'll probably do that eventually but for now I got kinda burned out. Thanks though.
  6. Final post. Last thing I tried is installing the game in my SSD. That didn't do it either. Options menu crashes and there's no reason to believe the game wouldn't freeze either. Sorry to waste your time but I give up on it. If you have anything that you think would help shoot but I doubt it. Thank you again for your help.
  7. Ok, now this is weird and it's safe to say I'm officially piffed off. Decided against using memcleaner and went straight to disabling physx. Game crashed at first but then I remembered I had the options to read only because of what that thread had suggested, so I changed that yet whenever I wanted to change ANYTHING in the graphics options the game just crashed outside of Shadow, effect and render details. I deleted the options txt so the game can generate another. Same issue. I changed the service pack and removed it, uninstalled the community mod, deleted the exe and verified files, used the sacred file cleaner utility tool, reinstalled the game, disabled steam overlay (even though it didn't work anyway) and it still crashed every damn time. I can live without physx but I'm not playing this game on low graphics (or in this case, medium) and no weather effects. Plus I kinda need vysnc for the 60 fps cap. Anyone willing to walk me through manually changing the options from the txt file? Edit: Clean installed new drivers. Didn't help either. Edit 2: Oh my god, I put the game on windowed mode and it worked. I can't believe the solution was so simple... Sigh. I'll keep you updated if the game crashes again without physx * Thank you for sticking with me through this Edit 3: Nevermind. Crashes seem to be happening when I switch back to fullscreen now. I managed to change mostly everything I want... so I guess I'll live with it for now. Someone telling me how to change each option from the txt file would be appreciated still. Edit 4: Physx is off. Game froze. I honestly don't know what else to do at this point.
  8. Tried service pack 3, windows vista compatability but it keeps happening. If I patch it with the 4gb patch I keep getting a load error when I launch the game. It's interesting though with windows vista comp the game just keeps crashing instead of freezing, makes it easier to close I guess. Alt tabbing out of the game regularly or ctrl + f1 every so often doesn't do anything either. Changed the options txt as suggested in the other thread as well. It helped with a few fps drops and stuttering but not with the crashing. I'll try memcleaner tomorrow and if that doesn't work I guess I'll disable physx. If it still doesn't work after that I'll be mildly piffed off. Edit: Haha, cool profanity filter
  9. I didn't try running it on SP3, only SP2. I'll try that first! Also, I did try the shortcut command but the post I read only mentioned one not both so I'll see if both of them work. No elite textures either and I like physx a bit too much I'll leave it as a last resort. If nothing of what flix suggested works I'll try Radon's way. I'll keep you updated and thank you! Edit: It seems like running the command options make all of the text in game disappear! So I guess I'll just stop that.
  10. Hello, new here. This should be under the correct category. Anyway. Apologies if this has been mentioned before. I'm having trouble with the game, as the title suggests it freezes every 2 hours or so. It seems to be happening at random. First time this ever happens to me, played this game before but not with the same PC. The game completely stops but the sound keeps going. A few times it only freezes for 5 seconds~ but most of the time the game just stops responding indefinitely. Tried running with windows XP compatability, validating game files, running as administrator and turning down the graphic settings just a bit. Nothing has helped so far. I don't have any mods installed, although I just installed the community mod. Haven't tried with that yet but I doubt it will do anything. I'd like to know if there's a fix to this. My specs: OS: Windows 10 pro 64 bit GPU: Gtx 970 4gb CPU: Intel core i7 4770k Ram: 8GB 1600mhz Resolution: 1080p 60hz (if it's needed for whatever reason)
×