Jump to content

Sign in to follow this  
altonsy

What is latest patch for original Sacred?

Recommended Posts

What's the latest patch for the original Sacred? Mine seems to have alot of bugs. I have version 1.8.2.10. Any info is greatly appreciated.

Share this post


Link to post

Hmm, not sure which version is the last if you are playing without Underworld, only thing I know is that with Sacred + Underworld the latest patch is 2.28.

Share this post


Link to post

Depends...........what version do you have?

US, European, Australian.

CD or download.

Do you have Plus installed?

With all that being said, I did a quick google and your version number does seem to be the latest anyway.

 

Apart from that, do yourself a big favor and try and get Underworld.

It contains a multiple of bug fixes and adds an enormous amount of content and extras to the game.

I just recently reinstalled my Sacred Underworld and it runs great with no bugs.

And as an added bonus the latest patch for Underworld also removes the cd check. :)

Share this post


Link to post

Thanks, Stubbie. I kind of figured that would be the case, but was curious if mine was the latest version or if I was missing something.

Share this post


Link to post

I already saw that link, anyway. The file was replaced by one for Halo by the host site.

Share this post


Link to post

And to answer the original question, the final patch for pre-UW was 1.8.x.6, where x is the number for your language version.

 

Also, Steam does Sacred Gold.

Share this post


Link to post

I have Sacred Gold and I keep getting error message that it will not run on a 64bit system. Is there anything I can do to get it to work. It is my favorate of the Sacred Gold Series. I do have the underworld as well. Thanks,

Share this post


Link to post

you should check if your game version of Sacred Gold (which contains the Underworld addon) is already 2.28 ..

if not, you need to download and install patch 2.28 which is the latest/last official version..

 

afaik, it fixes a few problems with certain OSes, like Vista/Win7 x64 bit, and removes the CD check copy protection which may cause problems too..=

Rotluchs!

Good seeing you back on the boards, and still as knowledgable on Sacred as always!

:)

 

gogo

Share this post


Link to post

afaik, it fixes a few problems with certain OSes, like Vista/Win7 x64 bit, and removes the CD check copy protection which may cause problems too..

it is the main problem. the 2.28 version runs without any problems with vista/7/8. (like many other games from that years)

second hint is to install in a own created folder (probably even not on C: ). that provides the UAC causing trouble.

Share this post


Link to post

BTW.... The latest patches for Sacred and Underworld are available HERE in the download's section.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...