Jump to content

lujate

Character permanently paralyzed

Recommended Posts

I made it to the Gar'Colossus tonight for the first time in Ice and Blood. During the fight, I loose the ability to move (I.e. neither W/S nor left-click works) and to cast any Combat Arts (right-click does nothing). I popped a couple of potions, thinking I was just stunned, but quickly realized it was more serious than that and hit F8 to teleport out. Even back in Orcish Byway I cannot move or cast Combat Arts. I have tried the Gar'Colossus twice and it happened both times. The first time, I rebooted my PC. The second time, I stood in Orcish Byway for 10 minutes, waiting to see if it would wear off. Everything else seems to work. I can change weapons and call up various character dialogs with the keyboard, as well as rotate the map. I can rotate and zoom the camera with the mouse, and left clicks work to interact with menus. Left clicks do not work to mount my Wind Serpent, open my Player Chest, etc. I teleported to the portal in Thylysium, but it was the same there.

 

I am running Ice and Blood on Win7 (32-bit), playing in SP mode.

 

Any ideas?

Share this post


Link to post

I've had a similar problem on rare occasions -- during combat all of a sudden I can't move. Teleporting does no good either, but a game restart always fixes the problem. It has seemed random for me -- not Gar'Colossus but rather ordinary mobs in the desert or swamp. I'm running the vanilla 2.43 patch under Vista-64, and usually SP as well.

 

There was a similar, common problem in Underworld. It was related to the "granny.dll" becoming corrupt. I'm not sure if Sacred 2 uses that, though

Share this post


Link to post

Are you running any mods? I would get something similar to this with my SW when I fought the Poison Lord. Since I uninstalled the Ci-Sacred mod I dont seem to have this issue "yet".

Share this post


Link to post

I made it to the Gar'Colossus tonight for the first time in Ice and Blood. During the fight, I loose the ability to move (I.e. neither W/S nor left-click works) and to cast any Combat Arts (right-click does nothing). I popped a couple of potions, thinking I was just stunned, but quickly realized it was more serious than that and hit F8 to teleport out. Even back in Orcish Byway I cannot move or cast Combat Arts. I have tried the Gar'Colossus twice and it happened both times. The first time, I rebooted my PC. The second time, I stood in Orcish Byway for 10 minutes, waiting to see if it would wear off. Everything else seems to work. I can change weapons and call up various character dialogs with the keyboard, as well as rotate the map. I can rotate and zoom the camera with the mouse, and left clicks work to interact with menus. Left clicks do not work to mount my Wind Serpent, open my Player Chest, etc. I teleported to the portal in Thylysium, but it was the same there.

 

I am running Ice and Blood on Win7 (32-bit), playing in SP mode.

 

Any ideas?

 

Yeah.. I got an unorthodox "fix" for stuff like this. My problem generally starts off when I first reload a character that was previously saved.

 

Here's what I did... I loaded the character in a multiplayer LAN game, same level as it was when the problem started. For some strange reason, it ignores the oddly saved bits in the save file and lets me move again. I then teleport back to the area near where I'm supposed to be and save the game again - away from the nearby monolith. For Orcish Byway, I generally save near the merchant at the bottom of the hill. After this, I save and exit and reload the game in single player mode and continue on.

 

Now which character are you currently playing? I have noted a few similar issues - but they were in the Crystal Region, with an Inquisitor, and it had to do with certain traps - the white crystal ones.

 

As Furian suggested - if you've got any mods in place, try removing them.

Share this post


Link to post

Good idea Furian and heya there gial & wolfie. :)

 

This happens to me as well from time to time. Most times there's nothing to do but restart the game but a few times I found it was my custom camera settings. Since a custom camera allows for much more freedom than intended my camera would get stuck sometimes. Changing my camera settings in game has on occasion resolved the problem. What I would change is the camera angle limit in game. Gameplay options. It's one of those four sliders. I think it's the 3rd down from the top. Slide it to the far right I think. The idea being to force the position of the camera directly overhead so as to get it out of any obstructions. It's as if the camera gets stuck under an obstructing plane close to floor level...

 

 

Good luck!

Share this post


Link to post

I am not running any mods. The problem goes away if I restart the game. I am playing a pyro HE. I did change the zoom setting on the camera, I will set it back and see if it helps.

 

Edit:

Wolfie2kX, my problem goes away when I restart the game, but I am willing to try anything so I created a LAN game to see if that helped.

 

Schot, I tried to set my camera back to the defaults (I am not sure exactly where they started).

 

After these two things, I tried again and it happened again (this makes 4 times). It seems to be that it hits me with something that knocks me back, and she is frozen like a statue. My HE does not know she is paralyzed, because last night when I tried to wait it out she was whining about not doing anything.

 

Edit:

The solution was right in front of me the entire time: "just do not get hit". :)

Due to the aiming issue with Incendiary Shower, I was using it in a Expulse Magic/Incendiary Shower combo. In the combo, IS aims itself and is generally spot on. The problem is that the longer cast time for the combo was causing me to pause long enough to get hit. By using IS by itself, I was able to keep moving and avoid getting hit. The occasional IS did miss by a mile, but that was better than the alternative.

 

I am still certain there is some issue there but I got around it.

 

Thanks guys!

Edited by lujate

Share this post


Link to post

Ah! Good stuff lujate. I'm glad you were able to work something out. Getting frozen often like that sure does spoil the fun huh. :)

Share this post


Link to post

Hmm...havent had that bug in a while, bit of a bugger when it happens though. Glad you worked out some form of workaround Lujate.

Share this post


Link to post

I've been looking into that one for a long time now. I got a hunch on what is causing it, but it is a bit troublesome to mend.

 

The characters prone to getting frozen when hit by pushback and knockback spelltokens have their model mesh (wireframe) directly on the ground (0 z-coordinate), while those who do not get frozen that easily have meshes floating a minor bit above ground (+0.237 on the z-axis).

 

I tried to check if it really is because of that, but was not able to reproduce the freezing error with the normal toon in many consecutive runs and there were so many other things to do for the cm patch. :/

Share this post


Link to post

I've been looking into that one for a long time now. I got a hunch on what is causing it, but it is a bit troublesome to mend.

 

The characters prone to getting frozen when hit by pushback and knockback spelltokens have their model mesh (wireframe) directly on the ground (0 z-coordinate), while those who do not get frozen that easily have meshes floating a minor bit above ground (+0.237 on the z-axis).

 

I tried to check if it really is because of that, but was not able to reproduce the freezing error with the normal toon in many consecutive runs and there were so many other things to do for the cm patch. :/

You lost me just after "pushback and knockback". :)

 

For me it happened consistently until I simply avoided being hit. I would glad to help in any way I can. Unfortunately, I have already defeated him on my current difficulty. I do not know if it helps, but I was playing a Pyro HE on her unique mount.

Share this post


Link to post

Having the exact same issue here.

 

It all started in the region where octogalomus is. There is a res shrine there and when I started to continue playing from there heading north, my char always got frozen.

 

I am quite certain that it doesn't have anything to do with stuns/knockbacks on your char, because I don't think those mobs there (orcs, piggies, goblins?) don't have any of that.

I just fought the first dragon you encounter in the seraphim's underground and it started to continously freeze my char again. I don't think they have knockback/stuns either, there are no magies afaik, just everyday normal mobs*g*. Now here is the thing and at least that's my certain impression that this is at least one possible reason: When I left octogalomus I heavily respeced (character editor) my char, causing dartin assault to be at 0.9 seconds cooldown. When blaming the problem on the short cooldown, I ate one or two runes to get it to 1.4 and my char never froze for a couple of hours. However, now as I saw the dragon fight coming, I again did some respec and doodads and had my DA to 1.0 seconds and ofc it started to get stuck after 5-10 minutes. Took me 3 takes to get from res shrine to dragon, and it's by god not far away ;[

The magic number seems to be 0.9 - 1.2 seconds. Or something alike.

 

I think it's kinda strage... a couple of guides suggest having the skill below 1 seconds, but how come they never encoutered this bug?

I am using custom camera settings too, will revert them to original state and try it again. My wild guess is, that the attack animation somehow can't keep up with that particular attack speed.

It happens with and without cm patch enabled.

 

Hope my 2 cents help you czevak giving it another look :D

 

if you need the current savegame where this bug happens: hotfile

Just activate one or two buffs and go on a killingspree with darting assault or RI/DA combo.

Edited by mr.ioes

Share this post


Link to post

Interesting.

 

This would suggest that the animation system is to blame for it, when a playing animation gets interrupted by another event. (Knockback, Pushdistance, or other interrupt.)

 

Would be nice to know if it only happens with certain animations or in general. Darting assault uses ANIM_TYPE_SM02, as is the highelves Firestorm. Coincidence?

Share this post


Link to post
Would be nice to know if it only happens with certain animations or in general. Darting assault uses ANIM_TYPE_SM02, as is the highelves Firestorm. Coincidence?

 

I guess - and to some excend hope - that it is no coincidence, indeed.

 

Revenged Impact never caused this bug to me and I have it now at 0.6 seconds cd, so we can assume that it was on every other higher cd before as well, working like a charm.

Edited by mr.ioes

Share this post


Link to post

It happens independently of wheter I am using a mount or not.

Adding a 0.3 sec regenerating ring didn't help.

Using the default cam options (without follow) didn't help either.

Share this post


Link to post

Sounds like similar symptoms, but a completely different issue.

Share this post


Link to post

Setups which cause the bug:

0.9/1.0 cd, 0.3/0.6 reg per hit, blowpipe, 1/2 buffs active, RI+DA combo, 1-10min until occurence

0.8 cd, 0.3 reg per hit, blowpipe, 0 buffs active, RI+DA combo, 1 min

1.0 cd, 0 reg per hit, blowpipe, 2 buffs active (+20,2% attackspeed), RI+DA combo, bug after 2 min against 2 walking rocks (1 shifting stone, 1 magma stone creature). Is there a site where I can lookup whether those creatures have stun/knockbar or not?

 

Setups which don't cause the bug:

0.8 cd, 0.3/0.6/0.9 reg per hit, blowpipe, 0 buffs active, DA solo ~30 min and no bug

0.9 cd, 0.3 reg per hit, blowpipe, 1 buff(bark) active, DA solo ~10 min

0.9 cd, 0.3 reg per hit, blowpipe, 2 buffs active (+20,2% attackspeed), DA solo ~10 min

 

About two hours of testing but I still don't feel like it is completely true and some of those statistics might be just (bad) luck.

However, summed up:

 

DA solo seems to work fine now or has ever done and I was mistaken when I said that DA solo cause the bug too.

RI+DA combo or any combo with DA in it - I don't know - seems to bug out under certain circumstances. Those circumstances boil down to having a low cd.

 

Will continue testing tomorrow, I WILL NOT GIVE UP ON MY POOR DRYAD :D

Edited by mr.ioes

Share this post


Link to post

I would sometimes find my SW stuck as well, though everything else would work. Heck, I can even rotate my SW as well, spinning like an idiot, just not able to walk. :P I don't know why it happens or how, it occasionally happens, but I was usually able to solve this problem by simply doing a Belligerent Vault. He leaps out of whatever he's stuck at, and he's fine once again. Of course, I don't recall ever having been unable to cast any CAs, just merely stuck in one spot.

Edited by Aegis

Share this post


Link to post

Made it to the Carnach today, and I am having the same problem. :(

Share this post


Link to post

It is the same Pyro HE and it still seems to be related to boss knock back, not anything I do.

Share this post


Link to post

I'd recommend using a mount.

Mounts prevent stuff. I used a unique mount to destroy colossus. He doesn't use many combat arts at all against me. Because I used protector familiar, and they aid me in combat, 2 of them, absorb all damage, unkillable.

You can hardly get knocked back, and that boss isn't hard individually.

Try using a mount for bosses. It ruins your game style, but, much better than being unable to get past that stage of the game.

It shouldn't crash then.

Edited by Legend Aadil

Share this post


Link to post

The Gar Colossus was with a pyro HE on her Wind Serpent. The Carnach was with the same character, but I cannot recall whether mounted or on foot.

Share this post


Link to post

The Gar Colossus was with a pyro HE on her Wind Serpent. The Carnach was with the same character, but I cannot recall whether mounted or on foot.

Carnach is in a cave, so you must've been on foot ;)

Share this post


Link to post

The Gar Colossus was with a pyro HE on her Wind Serpent. The Carnach was with the same character, but I cannot recall whether mounted or on foot.

Carnach is in a cave, so you must've been on foot ;)

Actually no, in SP it is possible to take your mount underground. When the game starts, you will always have your mount beside you. Since SP allows you to start underground, a viola, you have your mount underground.

 

I know that I to reload a couple of times to the Monolith in the Carnach Cave. I just cannot remember if I used my mount.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×