Jump to content
DarkMatters Celebrates
18 Years of Christmas in Ancaria

From the Sacred 2 Christmas Island Soundtrack
Click to Open Player!

Wardust

Deactivating the battle music

Recommended Posts

I was searching this for a lot of time with no results, but... it's very simple!

 

You must go to the scripts folder in the main directory and open "soundprofile.txt" (make a copy first ;-)

 

You can do a Search in the notepad for "music_fight"

 

Then you will find the three events "music_fight_easy" medium and hard together for every heroe (and bossmonster), and only you need to do it's write a "0" in the resource line you want(example=

"event527 = { event = "MUSIC_FIGHT_EASY", resource = 0 };)

 

Now you can get battle music only in hard moments and bosses, and normal music in the rest of campaing.

 

Play Well! ;-)

Edited by Wardust
  • Like! 1
Link to post

I never noticed this since I dont play with volume I listen to rap/dubstep anyway I think consoles can deactivate it in settings quit easily if im not mistaken

Link to post

Now you can get battle music only in hard moments and bosses, and normal music in the rest of campaing.

 

Very interesting find here Wardust! I think it's really cool that the coders divided up the music based on the difficulty of the encounter...more epic encounter = more epic music? Sweet :D

Link to post

Wardust thank you again for more music help!

 

By default it seems like all you hear is battle music, so I disabled it in custom options. But I still wanted battle music sometimes for the bosses and hard fights, so this is perfect solution!

 

EDIT: ...well it seems like changing the value to zero sometimes just creates silence instead of the battle music. But still a great thing.

Edited by Flix
Link to post

Not sure how I missed this when you first posted it, but thanks Wardust, this is great. After over three years, I can play the game with the music volume up and not get the repetitive battle music playing constantly. It's great to be able to hear the game music without having to put the CD in my player.

 

I could never get the Options_Custom thing to work, but this did.

Edited by Steerpike1
Link to post

Not sure how I missed this when you first posted it, but thanks Wardust, this is great. After over three years, I can play the game with the music volume up and not get the repetitive battle music playing constantly. It's great to be able to hear the game music without having to put the CD in my player.

 

I could never get the Options_Custom thing to work, but this did.

 

Well, if you want disable ALL de battlemusic, the best way it's edit the options.txt, setting the "volumegroup02" to 0 ;-)

Link to post

I was searching this for a lot of time with no results, but... it's very simple!

 

You must go to the scripts folder in the main directory and open "soundprofile.txt" (make a copy first ;-)

 

You can do a Search in the notepad for "music_fight"

 

Then you will find the three events "music_fight_easy" medium and hard together for every heroe (and bossmonster), and only you need to do it's replace the event, for example, with a footstep event, in the resource line you want

example:

event527 = { event = "MUSIC_FIGHT_EASY", resource = 1234567 }

event527 = { event = "FOOTSTEP_BARE_FOREST_L", resource = 74650 }

 

Doing this, you disable the music for easy fight, and the game continues playing the region music.

Now you can get battle music only in hard moments and bosses, or only for bosses, or only activate this for some heroes.

 

Play Well! ;-)

I have to edit the first post. When the resource it's = 0, the music stops (like say Flix), but replacing the entire event line results in continuing music (see edited quote in this post).

Regards!

  • Like! 1
Link to post

Thank you, I will have to try this new method very soon. I disliked how putting "resource=0" would result in silence sometimes. I think it also caused a problem where boss music would not stop playing (if boss music was not disabled of course) - it would continue forever and overlap with the exploring music. This was especially bad with summoning the Sakkara Demon.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
  • Create New...