Jump to content

Recommended Posts

Can someone try to download this file and see if the site throws out an error? Some users are unable to get to the download because the site is giving an error, but on the other hand I'm able to download it just fine. So it's tagged as a broken file until it gets resolved, and I'd rather get the red flag removed ASAP.

Share this post


Link to post

Downloaded without any issues here...I didn't try and install as I don't have Sacred on my pc anymore though.

  • Like! 1

Share this post


Link to post

Looks good here too.

  • Like! 1

Share this post


Link to post

Thanks everyone. Could an admin or mod please unflag this file as broken? Because it doesn't seem there's anything wrong with it and I don't want people avoiding the download because of that red flag.

  • Like! 1

Share this post


Link to post

Thanks everyone. Could an admin or mod please unflag this file as broken? Because it doesn't seem there's anything wrong with it and I don't want people avoiding the download because of that red flag.

And done!

Thanks Flix

 

:)

 

gogo

  • Like! 1

Share this post


Link to post

Thanks Gogo!

 

Anyone that might have trouble downloading it can also get the file on Sacred 2 Nexus HERE.

  • Like! 1

Share this post


Link to post

I just updated the file by removing the Enhanced Spells Compatibility Patch and updating the documentation. This change was just for the benefit of new users. Previous users don't have to download it again, just note that if you have the latest version of Enhanced Spells (1.3) you no longer need a compatibility patch. Just be sure to install Elite Mounts THEN Enhanced Spells.

  • Like! 1

Share this post


Link to post

Elite Mounts mod has a new version up. v1.10 adds localizations for French, German, Polish, and Russian languages. So players with these versions can now play the mod and have names for the mounts. And Enhanced Spells also plays with this mod in any of the aforementioned languages (install Elite Mounts first).

 

Thanks to Pesmontis for the German names and VAMPIRE for the French. For Polish and Russian I just copied over the names from the vanilla special mounts (Hellhound, Sabertooth, etc.), but at least they have proper names now.

 

So, English players wouldn't really need to download it again since the only content added is new translations.

  • Like! 1

Share this post


Link to post

Download page is down. Get the mod from the Nexus until it can be restored on DarkMatters:
http://www.nexusmods.com/sacred2/mods/3/?

 

EDIT: Download page is back up. Download stats, previous versions, and changelog are reset, but everything seems to working fine.

Edited by Flix
  • Like! 1

Share this post


Link to post

Elite Mounts now has a Spanish language patch available for download on the file page. The version on the Sacred Nexus has also been updated.

Just extract the contents of the patch zip file into the Elite Mounts mod folder and overwrite.

  • Like! 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×