Jump to content
SevPOOTS

Sacred Gold's Low FPS?

Recommended Posts

SevPOOTS    89

Hello! Im back lol

 

Reinstallef sacred gold and also have fraps installed. Tried playing on max quality windowed mode and when Im super zoomed in I only get 30 fps , when Im half zoomed about 26 then when Im fully zoomed out, I get 10,- 15 fps

 

Its kinda weird thought that I can play sacred 2 with no lag at all on med settings.

 

Is therebsomething that can make the game run on 60fps?

 

i3 / Intel hd 4000 / 2gb ran

  • Like 1

Share this post


Link to post
Share on other sites
gogoblender    1,464

Hello! Im back lol

 

Reinstallef sacred gold and also have fraps installed. Tried playing on max quality windowed mode and when Im super zoomed in I only get 30 fps , when Im half zoomed about 26 then when Im fully zoomed out, I get 10,- 15 fps

 

Its kinda weird thought that I can play sacred 2 with no lag at all on med settings.

 

Is therebsomething that can make the game run on 60fps?

 

i3 / Intel hd 4000 / 2gb ran

welcome back SevPOOTS!

 

:)

 

gogo

Share this post


Link to post
Share on other sites
Hooyaah    1,059

Without looking at all of your machine's specs, I would agree that a new GPU is a good idea. I personally recommend a Nvidia GeForce GTX series or better. You may go to their website and check out what's available and affordable. Always be sure to do a driver update after installing the new graphics card. I second Gogo's greeting: welcome back!

Share this post


Link to post
Share on other sites
SevPOOTS    89

Thanks guys! It might be that sacred is not compatible with windows 8? Tried everything and I can only get 30fps when medium zoomed.

 

Well, thats the magic of it I think. I also agree with everyone here. The fantasy setting or charm of Sacred Uw is what makes ne want to play it,<3

 

I remembered the time I bought it and the clerk actually helped me install it. I was like "Is that an angel with twintails?"

 

I was sold. XD

  • Like 1

Share this post


Link to post
Share on other sites
Hooyaah    1,059

Sir Sev of POOTS, you should try running the game in compatibility mode. To do this right click on the Sacred 2 icon that starts Sacred 2 then select "Troubleshoot Compatibility." You can first tell it to run with recommended settings, if that fails then tell Windows to run the Game in Windows XP Service Pak 2. Also, do be sure to download the most recent version of Microsoft NET Framework and the most recent driver for your GPU. If that doesn't work I'll have to fly there and get it going for you, on second thought I might want to take a plane. Of course you could simply run it in medium settings too. The grass and other flora seems to really drag down the FPS.

 

 

  • Like 2

Share this post


Link to post
Share on other sites
SevPOOTS    89

Thanks gogo! You too. I have 4days off so I will play sacred 1 and 2 indefinitely. I love how you still keep this forum alive (together with the other active members ) :)

Share this post


Link to post
Share on other sites
gogoblender    1,464

Thanks gogo! You too. I have 4days off so I will play sacred 1 and 2 indefinitely. I love how you still keep this forum alive (together with the other active members ) :)

 

 

:hugs:

 

gogo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×