Jump to content
Poroner

Game freezes after 2~ hours of gameplay

Recommended Posts

Poroner    3

Hello, new here. This should be under the correct category. Anyway.

Apologies if this has been mentioned before.

I'm having trouble with the game, as the title suggests it freezes every 2 hours or so. It seems to be happening at random. First time this ever happens to me, played this game before but not with the same PC. The game completely stops but the sound keeps going. A few times it only freezes for 5 seconds~ but most of the time the game just stops responding indefinitely.

Tried running with windows XP compatability, validating game files, running as administrator and turning down the graphic settings just a bit. Nothing has helped so far.

I don't have any mods installed, although I just installed the community mod. Haven't tried with that yet but I doubt it will do anything. I'd like to know if there's a fix to this.

 

My specs:

OS: Windows 10 pro 64 bit
GPU: Gtx 970 4gb
CPU: Intel core i7 4770k
Ram: 8GB 1600mhz
Resolution: 1080p 60hz (if it's needed for whatever reason)


  • Like 1

Share this post


Link to post
Share on other sites
Flix    2,969

Hello! Welcome to DarkMatters.

From what I understand this is tied to a memory leak problem. The game uses up more and more memory and once it hits a threshold (1.5GB I believe) it freezes as you describe.

  • Run in compatiblity for Windows XP SP3 (looks like you've got this covered)
  • Disable PhysX
  • Disable Elite Textures if you have them installed
  • I use this program because like you I'm on a 64-bit system - 4GB Patch
  • Running this program has been recommended on the forums. I haven't tried it myself - MemClean


I also do this to the Sacred 2 shortcut:

  1. Right click the shortcut and select properties
  2. Click the Shortcut tab
  3. In the Target field, you need to add the following: -skipopenal -nocpubinding. The contents of the target field would look like this (for Steam): "C:\Games\Steam\SteamApps\common\sacred 2\system\sacred2.exe" -skipopenal -nocpubinding
  4. Click Apply and Click OK.


Here's some other threads on the topic:
http://darkmatters.org/forums/index.php?/topic/15390-sacred-2-freezes-when-memory-use-is-more-than-15g-ram/
http://steamcommunity.com/app/225640/discussions/0/864956554687300470/?l=english

 

Some users have reported simply alt-tabbing out of the game every 15 minutes or so refreshes the memory enough to keep it stable.

 

Good luck. I hope you can get it running smoothly.

  • Like 2

Share this post


Link to post
Share on other sites
King Angel    58

I used Flix method but game crash. I make this configuration and work great :D

1. Right click on "Troubleshoot Compatibility" ---> "Try Recommanded Settings" ---> "Test The Program" --->"Yes, save this settings for this program" ---> "Close"

And:

2. Right Click on shortcut "Properties" ---> "Compatibility" check "Run as administrator and Windows Vista" ---> "Security" ---> "Edit" and there select for each Group select "Allow"

This is my settings and work great on Windows 10

NOTE: I don't say Flix method don't work but for me game crash :(

  • Like 2

Share this post


Link to post
Share on other sites
Poroner    3

I didn't try running it on SP3, only SP2. I'll try that first!

Also, I did try the shortcut command but the post I read only mentioned one not both so I'll see if both of them work.

No elite textures either and I like physx a bit too much I'll leave it as a last resort.

 

If nothing of what flix suggested works I'll try Radon's way.

I'll keep you updated and thank you!

 

Edit: It seems like running the command options make all of the text in game disappear! So I guess I'll just stop that.

Edited by Poroner

Share this post


Link to post
Share on other sites
Flix    2,969

I didn't try running it on SP3, only SP2. I'll try that first!

Also, I did try the shortcut command but the post I read only mentioned one not both so I'll see if both of them work.

No elite textures either and I like physx a bit too much I'll leave it as a last resort.

 

If nothing of what flix suggested works I'll try Radon's way.

I'll keep you updated and thank you!

 

Edit: It seems like running the command options make all of the text in game disappear! So I guess I'll just stop that.

 

Ok, I think the shorcut options would improve performance generally but they're probably not tied to the freezing problem.

 

My money is on PhsyX right now. But I understand the effects are neat.

  • Like 1

Share this post


Link to post
Share on other sites
Androdion    223

PhysX makes the game look extremely beautiful but it also makes it unstable as all hell. I'd definitely take it out.

Share this post


Link to post
Share on other sites
Poroner    3

Tried service pack 3, windows vista compatability but it keeps happening. If I patch it with the 4gb patch I keep getting a load error when I launch the game.
It's interesting though with windows vista comp the game just keeps crashing instead of freezing, makes it easier to close I guess.
Alt tabbing out of the game regularly or ctrl + f1 every so often doesn't do anything either.
Changed the options txt as suggested in the other thread as well. It helped with a few fps drops and stuttering but not with the crashing.
I'll try memcleaner tomorrow and if that doesn't work I guess I'll disable physx. If it still doesn't work after that I'll be mildly piffed off.

 

Edit: Haha, cool profanity filter

Edited by Poroner
  • Like 1

Share this post


Link to post
Share on other sites
gogoblender    1,502

Edit: Haha, cool profanity filter

 

Indeed ^^

And sorry you're having such problems with such a gem of a game

But very happy you've found us and that the community has helped out here

thanks for the profanity filter compliment

 

:D

 

gogo

  • Like 1

Share this post


Link to post
Share on other sites
Poroner    3

Ok, now this is weird and it's safe to say I'm officially piffed off.

Decided against using memcleaner and went straight to disabling physx. Game crashed at first but then I remembered I had the options to read only because of what that thread had suggested, so I changed that yet whenever I wanted to change ANYTHING in the graphics options the game just crashed outside of Shadow, effect and render details. I deleted the options txt so the game can generate another. Same issue. I changed the service pack and removed it, uninstalled the community mod, deleted the exe and verified files, used the sacred file cleaner utility tool, reinstalled the game, disabled steam overlay (even though it didn't work anyway) and it still crashed every damn time.

 

I can live without physx but I'm not playing this game on low graphics (or in this case, medium) and no weather effects. Plus I kinda need vysnc for the 60 fps cap. Anyone willing to walk me through manually changing the options from the txt file?

 

Edit: Clean installed new drivers. Didn't help either.

 

Edit 2: Oh my god, I put the game on windowed mode and it worked. I can't believe the solution was so simple... Sigh. I'll keep you updated if the game crashes again without physx * Thank you for sticking with me through this :P

 

Edit 3: Nevermind. Crashes seem to be happening when I switch back to fullscreen now. I managed to change mostly everything I want... so I guess I'll live with it for now. Someone telling me how to change each option from the txt file would be appreciated still.

 

Edit 4: Physx is off. Game froze. I honestly don't know what else to do at this point.

Edited by Poroner

Share this post


Link to post
Share on other sites
Poroner    3

Final post. Last thing I tried is installing the game in my SSD. That didn't do it either. Options menu crashes and there's no reason to believe the game wouldn't freeze either. Sorry to waste your time but I give up on it. If you have anything that you think would help shoot but I doubt it. Thank you again for your help.

Share this post


Link to post
Share on other sites
Veracious    207

 

Final post. Last thing I tried is installing the game in my SSD. That didn't do it either. Options menu crashes and there's no reason to believe the game wouldn't freeze either. Sorry to waste your time but I give up on it. If you have anything that you think would help shoot but I doubt it. Thank you again for your help.

I've told this to other people. Your best bet is to just keep an old hard drive with winxp installed on it for old 32- bit games. A hard drive hot swap is cheap enough and you'll never have comparability issues. I have a second os on my hd specifically for old games because I only own one hard drive. But keeping xp somewhere is your best bet.

Edited by Veracious
  • Like 2

Share this post


Link to post
Share on other sites
Poroner    3

I'll probably do that eventually but for now I got kinda burned out. Thanks though.

  • Like 1

Share this post


Link to post
Share on other sites
Zallk    22

Sometimes it seems like most people that have problems running the game are on the Steam version. I wouldn't know if there's really any difference, but I've never had trouble with my copy from GoG and it doesn't force me to log into any interface or extra program.

 

Running 64 bit OS and with comm patch + mods (enhanced spells, reduced fog, flix music), and camera tweaks for better world view (TPOmax 90, trackdistancemin 75, compass 0 in options.txt). The only time I've ever had even so much as framerate slowdown was when I tried turning on Physx, so I leave it off. Never crashes on me. GoG has it on winter sale right now. Not sure if they have a refund program, in case you buy it from them and it still crashes on you....

  • Like 1

Share this post


Link to post
Share on other sites
Poroner    3

I'd rather not risk it and I don't feel like paying again for a game I payed outside of a sale for. Besides as soon as I get my hand on an empty disk or a usb I'll install xp. Yeah yeah I know, I don't have any right now :P

Share this post


Link to post
Share on other sites
Hooyaah    1,121

This thread may be a bit stale now, but I wanted to mention that I have Windows 7 and it works great using compatibility mode set for XP Service Pack III. I also have the GOG version and they sell the game at a good price, although I understand not wanting to pay for something twice. I like Veracious' suggestion for using a drive with XP to play the game. One could have both drives installed and chose to boot from either drive. Upgrading to Windows 7 may work too but it, like another drive, is not free either. I'm not sure how long you are playing the game before you have a crash but I have found that if I have done much traveling across the map and have played for over an hour (especially the Bloodwood) the game may crash for me too. I park my toon in a safe location to spawn in and press the F10 key. I exit the game fully and when I load the character again I'm right back in the game again without the memory overload being a problem. I hope this post helps any person reading this who is be experiencing the same issue. I admire the members here (thanks to you all) for being so willing to help, thoughtful, and patient. That's one thing about Dark Matters as a community that I admire, great members and a vast amount of information, ideas, downloads, mods, etc. is cool too.

 

Welcome to Dark Matters, Poroner!

  • Like 1

Share this post


Link to post
Share on other sites
swocgenius    1

Windows 10 is the problem

I've tried most the fixes in this forum,none work any good

BUT.

I happened to turn the MUSIC off,moved the slider all the way to zero,and bingo Sacred 2 is working for the most part,

although the temple guardian is still a bit twitchy,but even him I played o.k.

Can't hurt to try turning the music off

  • Like 1

Share this post


Link to post
Share on other sites
Androdion    223
11 hours ago, swocgenius said:

Windows 10 is the problem

I've tried most the fixes in this forum,none work any good

BUT.

I happened to turn the MUSIC off,moved the slider all the way to zero,and bingo Sacred 2 is working for the most part,

although the temple guardian is still a bit twitchy,but even him I played o.k.

Can't hurt to try turning the music off

You can always try the beta version of the new CM Patch 1.60: 

The game is said to be 99% crash free with this. Do try it and give some feedback! ;)

  • Like 1

Share this post


Link to post
Share on other sites
Poroner    3

So I'll try a combination of the fixes here. I was looking for something to play again and bam this thread pops up! I'll install the beta CM patch, lower the volume slider and play with physx off. I don't want to keep restarting the game because the crashes happen every 1-2 hours. 

Another thing, there was another game I played that the GOG version worked perfectly while the steam one had problems. What they did is get the .exe from the gog game directory and replace the steam one with it (Basically cracking) and the game worked perfectly. 

It wouldn't hurt sharing the gog .exe. :blush:

Share this post


Link to post
Share on other sites
Androdion    223

In my honest opinion there's no need for the extra steps. Just try the CM Patch beta and see the added stability for yourself. If you need any help in setting up things just drop a line in that topic.

Share this post


Link to post
Share on other sites
Poroner    3

Perhaps but I tried all three regardless and no crashes so far! I must have around 4 or so hours of gameplay with a new character and the game is smooth as butter. 

Now, all the other times I tried to play it took a while before the crashes started happening but this is a good sign. I've also been monitoring RAM usage and no leaks there. It probably is the patch that fixed it but I'm scared of turning on physx regardless in the off case it screws something up and then physx on or off it keeps crashing again (like my options menu kept crashing for no reason at some point even after a reinstall lol...) and music I don't really care for so much. I just listen to other things when I play this game anyway. 

Not playing that much now but when I hit around 15 hours of gameplay I'll be sure if the issue is fixed or not but anyway, this seriously made my week. Thank you all for your help. 

Edited by Poroner

Share this post


Link to post
Share on other sites
Androdion    223

No problem, glad you're having fun. :)

I've been playing for a couple of months now with both Elite Textures and Physx with no random crashes. The game runs smooth and crash free with it, so you can try enabling the stuff you disabled one by one if you will.

Share this post


Link to post
Share on other sites
Poroner    3

Will do for sure once I'm sure it actually works. :D 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×