Jump to content
Hooyaah

Game Crashing Or Other Issues With PhysX Enabled?

Recommended Posts

Hooyaah    1,059

If you are having a problem when using PhysX effects in Sacred 2 there may be hope and sometimes without upgrading RAM, your video card, or processor. It depends of course upon whether your display adapter and other components meet certain minimums but if you are already able to play on very high quality settings your rig will likely be able to handle PhysX turned on.

 

 

Try this: Open the manufacturers control panel for your video processor and check what processor is selected to handle the PhysX effects. If your CPU* is selected or it is set to auto-select then select the video processor instead. It is most likely better equipped to handle the PhyX effect with no difficulty. I hope this helps any fellow gamers who are yet experiencing this potentially frustrating issue.

 

EDIT

 

* Note: PhysX may only function by employing a PhysX PPU or a CUDA-Enabled Nvidia CPU with at least 32 cores and 256 MB of dedicated on-board graphics memory.

Edited by Hooyaah
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×