Jump to content


Sign in to follow this  
Flix

Community Patch 1.60 Beta Test Release

Recommended Posts

 
10 hours ago, Flix said:

General testing, mostly.  It would be most helpful if people would just kind of comb through the changelog and verify whatever they can.

XP per Kill stacking - no reports on how this has been received

Item stacking - is everything stacking correctly?  Runes, trophies, potions.  Got a report on MantisBT this week that 4-Leaf Clover trophies weren't stacking anymore.

Travel Agents and new "portals" - any issues?  Should I change the icon from the old ship icon to my new design, since many of them are neither ships nor captains?

Quests - Faust - need to check it's behaving properly.  Arena fighting quests got rescripted by Marcus - these need to be verified that they're working well.  The quest "The Usurer" (Thylysium, Shadow Path) also previously got lots of complaints - need to check it's behaving well.

Buff slots and potion slots available when shapeshifting and mounted on horses - working OK?

Those are the main ones that need testing.

Dmitriy is still trying to hammer out a way to get the spikeshield VFX (granted to minions by SW's Reflective Emanation) to no longer cause low FPS - right now we just have the FX removed entirely.  So, internal testing for that is ongoing.

Stacking is working fine for me on runes, potions and trophies. Though I haven't changed difficulties nor collected all kinds of trophies so can't vouch for each and every one.

Travel agents should probably have their own icon since it does get a bit confusing to have a captain's icon. You begin to think about those balloons on the I&B regions, and they're not like them, so a new icon would perfectly differentiate the three different kinds of teleportation.

Can't speak for the remaining things, sorry. Like I said earlier in the week I'll be AFK tomorrow onwards and for the whole week, so I won't be of much help in the next few days. But I'll keep an eye on this thread via mobile anyway.

  • Thanks! 1

Share this post


Link to post
 
4 hours ago, VAMPIRE said:

 Hi to all friends. I just read the full change log. There is everything I expected since a long time. I'm really impressed: Starting Island Portal is enabled in singleplayer,  stackable items and a thousand other beautiful things. Congratulations to the entire team who is working on this titanic project. A big thank you and a lot of courage for the work ahead...  

   My sincere friendships to the whole forum   :)

Good seeing you back here Vampire, your encouraging energy is always a happy read

:)

 

gogo

  • Like! 1

Share this post


Link to post
 
4 hours ago, Androdion said:

Travel agents should probably have their own icon since it does get a bit confusing to have a captain's icon. You begin to think about those balloons on the I&B regions, and they're not like them, so a new icon would perfectly differentiate the three different kinds of teleportation.

Yeah, it's kind of the opposite though.  There's now basically one type of transportation, since everything acts like a portal.  That's why the new icon replaces the ship at sea with an icon similar to a portal. It reminds people that "ports," be they captained by sea, air, or magic, are now reachable from the world map like portals.

The steering wheel icon remains the same, because it's immediately recognizable.  If I changed it, it would change for all captains.  I can't split them up into groups, since they're all the same captain NPC type.

Share this post


Link to post
 
34 minutes ago, Flix said:

all the same captain NPC type

If I recall correctly, travel can be initiated by either JOB_CAPTAIN, or JOB_TRAVELTRADER. I've never checked, whether the icon is the same, though.

Share this post


Link to post
 

Oh, I got it wrong then. So captains at ports once "activated" act like portals as well? Same for balloons? I'd prefer for it to be as it was with only the new NPCs being treated as portals, but if it that can't be had then I'm ok with it anyway. But in that case I'm not sure about the icon change. Some other user should leave their input about that.

Share this post


Link to post
 
42 minutes ago, Androdion said:

I'd prefer for it to be as it was with only the new NPCs being treated as portals

It was never like that.  The new NPC's are and were always ship captains.

The ports=portals change preceded the idea of adding more captains.  It is separate and IMO the more important change.  The original project was: "we need to add portals to places like Artamark's Gate, because right now the only way up there is through the ship port."  The breakthrough was when we were able to just make ports act like portals.  So the list of places that needed portals became the list of places that got ship captains.  It's all right there in the post.

Share this post


Link to post
 

You're right. It only comes to show how much I'm in need for these vacations. I remember posting in that thread, but between then and now I just didn't remember the content.

Now that I've reread everything I'll say that you should change the captain/travel agent NPCs' icons to the new portal icon with the green arrow, since all ship ports and air balloons will also act like (extra) portals.

Once again, sorry for the mixup with things we've already discussed. I must be getting old...

Share this post


Link to post
 
1 hour ago, Androdion said:

Once again, sorry for the mixup with things we've already discussed. I must be getting old...

You and me both.  Don't sweat it.

 

New version is uploaded.  Change log is updated too. 

This version includes some updated dll's that should help with resource handling and CTD's in windowed mode.  The new version also reverses the changes to Combat Alert and Reflective Emanation on minions.  These fx are restored to vanilla designs, with the problematic FPS drops associated with them removed.  In fact, all buff FX that were causing FPS drops should now be silky smooth. Thanks Dmitriy for sticking it out and finding the solution.  Finally, the new icon for ports is included.  It is a combination of the portal and mini-portal icons.

  • Like! 1

Share this post


Link to post
 
 

Picked up my Niob HE and activated all travel agents. She has Shield Lore mastery so she can run around barely scratched. :D

After activating all of them I downloaded the latest update and teleported back and forth through all twenty of them. All are working perfectly and all icons and titles are correct, unless my eyes are deceiving me. But I'm 99,99% sure they aren't. ;)

I activated all twenty travel agents in a single session, and if such a monumental task performed with ET/Physx/AA/AF on and LL effect Magic Coup didn't crash the game I don't think anything will. Seriously people, I'm astonished! I don't remember the game being so stable ever since I played the vanilla FA v2.40!

Took a look at the spikeshield animation too, works extremely fast. No slowdows, just breezes through.

  • Thanks! 1

Share this post


Link to post
 
1 hour ago, Menolly4 said:

I'm new in this forum, so at first thanks to the whole team providing the patch. It is great!!

Now my Question:

Has someone found a part of the Slagelamber's Relics miniset recently?

I play the game for several years now. I can't remember finding one piece of the set since installing Ice & Blood.

I hoped with CM.patch 1.60 pieces of the set would drop again.

 

Thanks for trying the beta patch and posting here!  Welcome to DarkMatters.  Slagelambers is now added to the drop lists where it belongs.  But, it is still rare.  The best chance to find it is to fight bosses.  Mini-sets are set up to drop most commonly from bosses.

 

1 hour ago, Androdion said:

Picked up my Niob HE and activated all travel agents. She has Shield Lore mastery so she can run around barely scratched. :D

After activating all of them I downloaded the latest update and teleported back and forth through all twenty of them. All are working perfectly and all icons and titles are correct, unless my eyes are deceiving me. But I'm 99,99% sure they aren't. ;)

I activated all twenty travel agents in a single session, and if such a monumental task performed with ET/Physx/AA/AF on and LL effect Magic Coup didn't crash the game I don't think anything will. Seriously people, I'm astonished! I don't remember the game being so stable ever since I played the vanilla FA v2.40!

Took a look at the spikeshield animation too, works extremely fast. No slowdows, just breezes through.

It's been the same for me.  Thanks for reporting in.  I'm glad others are having the same smooth stable experience.  I think we've really pulled it off.  

Share this post


Link to post
 
1 hour ago, Menolly4 said:

I'm new in this forum, so at first thanks to the whole team providing the patch. It is great!!

Now my Question:

Has someone found a part of the Slagelamber's Relics miniset recently?

I play the game for several years now. I can't remember finding one piece of the set since installing Ice & Blood.

I hoped with CM.patch 1.60 pieces of the set would drop again.

 

Just here to welcome you Darkmatters, Menolly4, have fun here with the mod!

 

:)

 

gogo

Share this post


Link to post
 
 

I just played sacred 2 LAN with my brother for roughly 5-6 hours and I have noticed at least 1 mayor bugs and my brother crashed 2 times.

 

My brother's first crash was nothing I took note of, he crashed and launched the game quickly. The second crash he froze and the quest update sound kept playing on repeat. The game was completely frozen and he had to logout because the game was on top of everything so he couldn't turn it off in the task manager.

The bug I saw was with seraphim's shield. Using ward energy buff or divine protection I got under half of what I should be getting

 

Also once a rune is stacked I can't go and turn them in for a new rune, can I un-stack them?

also thanks for the patch again, aside from the seraphim low shield everything is better

20171002212643_1.jpg

20171002212641_1.jpg

Edited by Recath

Share this post


Link to post
 

Here's the regular buff

 

She was created today in this patch, I have tried restarting the game and such

20171002211020_1.jpg

20171002211023_1.jpg

Edited by Recath

Share this post


Link to post
 
1 hour ago, Recath said:

Using ward energy buff or divine protection I got under half of what I should be getting

Confirmed. An early iteration (15.07.2017) s2logic.dll unintended change, that was somehow omitted. Affects energy shield multiplication. Stupid me. Well, it's fixed now and the effect is gone, once Flix updates the file set.

1 hour ago, Recath said:

he crashed

1 hour ago, Recath said:

The second crash

Do you have any specifics, system log messages?

Edited by dimitrius154

Share this post


Link to post
 
1 hour ago, Recath said:

can I un-stack them?

Yes, the SHIFT + Left Click opens the stack separation dialogue.

  • Thanks! 1

Share this post


Link to post
 

Does your brother have any specific sound settings perhaps? I got the same stuck sound crash and I had several channels sound configured. After I configured the sound settings to windows definitions the game behaved normally.

Share this post


Link to post
 

Download is updated w/ fix for wrong Energy Shield levels.  Glad we caught that one!  One hopes there's no more surprises like that hidden in there...

Share this post


Link to post
 
54 minutes ago, Flix said:

Download is updated w/ fix for wrong Energy Shield levels.  Glad we caught that one!  One hopes there's no more surprises like that hidden in there...

I'll post if I notice more ^^

 

3 hours ago, dimitrius154 said:

Do you have any specifics, system log messages?

nope, but if you tell me how I can get that I'll provide them, his crashes felt standard for sacred 2 so idk. He runs windows 10 and neither launch nor opening a game takes long times as for me, so I guess those 2 are just me as well, as I posted earlier. Just wanted to mention that

Edited by Recath

Share this post


Link to post
 
5 hours ago, Recath said:

but if you tell me how I can get that I'll provide them

Run eventvwr.msc, then open Windows Logs -> App Logs. Search for error events with Sacred 2 directory in the description.

 

5 hours ago, Recath said:

neither launch nor opening a game takes long times as for me,

Try the following: your brother starts the LAN game session, then you join it.

 

5 hours ago, Recath said:

One hopes there's no more surprises like that hidden in there...

 

I keep all changes as iterations of the dlls and can always backtrack things. That experimental tweak slipped in between two minor iterations in the early stage of the effort. Don't recall, why it stayed - it was about 4 AM:coffeecup:.

  • Like! 1

Share this post


Link to post
 

Hello @ all!

I'm new to the forums and at first I want to thank you for your work on this lovely game developed so many years ago - your work is really impressive!

Yesterday I tryed the new 160 Beta Patch via LAN with my girlfriend and while it was working fine for me, she is experiencing real problems:

First the game started up and everything seemed fine, I changed some gfx-options and when I hit the "accept" button in the menue, the game crashed... So I killed the (still running) task from the task-manager and tried to start it up again, but in the moment the intro should show up the game crashes again - nothing I can do about it anymore (tried everything you mentioned in this thread, also with options.txt and so on). So I copied the whole Sacred 2 Gold Edition folder from my PC to hers and yeah, it started up again! We ignored the gfx-settings and started playing - everything fine for about an hour, then she accidentially alt+tabbed out of the game and the game crashed again. Since then it's like before - the game crashes on startup when the intro should show up...

We have played together with the 150 community patch long time before and everything was fine, so we deactivated the 160 Patch and the game starts up again... Activated the 160 patch - crashed again on startup....

My System:

Intel Core i7 4970x4 4Ghz, 16GB RAM, Geforce gtx 980 ti

My girlfriends system: AMD Phenom 2x6 1090T 3,2 GhZ, 16GB RAM, Geforce gtx 650 ti

I've installed the newest version of all drivers on the systems.

I've also looked into the windows event-log like mentioned above and I attach the errors most showing up (most of them repeating a lot of times because I tried get it running the whole day, so I only added them one time).

I hope you can help and thanks again for your amazing work!

event-log.txt

 

Update 1: We now retry playing the game while we plug off her headset - the game started up again now, I tell you our experience afterwards...

Update 2: After she Alt-Tabbed out of the game there is the same issue as before... Game crashed and now it crashes on startup again... If I should try something else, please tell me...

Edited by Lichtbringer
Tryed something new
  • Like! 1

Share this post


Link to post
 
1 hour ago, Lichtbringer said:

I changed some gfx-options

Do your monitors support the same maximum resolution?

Share this post


Link to post
 

Hi Dimitri!

Yes, both monitors are at 1920x1080.

We are playing Patch 150 at the moment without problems...

Thanks for your answer!

Edited by Lichtbringer
  • Like! 1

Share this post


Link to post
 
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
  • Create New...