Jump to content
Hooyaah

Community Patch 160 Bug Reports

Recommended Posts

Hooyaah    1,473

Greetings fellow Sacred 2 Enthusiasts, this it the place where we would appreciate comments regarding any of your problematic or bothersome experiences playing the Completed Community Patch 160 (not the Beta, please). If you have any inexplicable glitches such as failed quests for no reason, missing or incorrect items, or things designated as changed in the release notes that do not appear to be present as expected, please address them here. Thank you in advance for staying on topic, so as to make it easier to respond to any reported issues promptly. Your assistance in helping us to improve your gaming experience is appreciated.

  • Like 1

Share this post


Link to post
Share on other sites
Dhampir113    2

Today the game crashed,I ran to Thylysium, took the quest "Robbery" and the game flew out as soon as I approached the crossroads to Thylysium. Sorry for my bad english/

Имя сбойного приложения: sacred2.exe, версия: 2.65.2.0, метка времени: 0x4be45a9b
Имя сбойного модуля: PhysXCore.dll, версия: 2.7.5.43, метка времени: 0x5487eeba
Код исключения: 0xc0000005
Смещение ошибки: 0x00193719
Идентификатор сбойного процесса: 0x1fe8
Время запуска сбойного приложения: 0x01d37746ed9ea8c3
Путь сбойного приложения: D:\Games\Steam\steamapps\common\Sacred 2 Gold\system\sacred2.exe
Путь сбойного модуля: C:\Program Files (x86)\NVIDIA Corporation\PhysX\Engine\v2.7.5\PhysXCore.dll
Идентификатор отчета: d42264d5-3eee-42c8-839b-173967275811
Полное имя сбойного пакета: 
Код приложения, связанного со сбойным пакетом:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2017-12-17T15:05:09.960954400Z" /> 
  <EventRecordID>3835436</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>DHAMPIR-PC</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>sacred2.exe</Data> 
  <Data>2.65.2.0</Data> 
  <Data>4be45a9b</Data> 
  <Data>PhysXCore.dll</Data> 
  <Data>2.7.5.43</Data> 
  <Data>5487eeba</Data> 
  <Data>c0000005</Data> 
  <Data>00193719</Data> 
  <Data>1fe8</Data> 
  <Data>01d37746ed9ea8c3</Data> 
  <Data>D:\Games\Steam\steamapps\common\Sacred 2 Gold\system\sacred2.exe</Data> 
  <Data>C:\Program Files (x86)\NVIDIA Corporation\PhysX\Engine\v2.7.5\PhysXCore.dll</Data> 
  <Data>d42264d5-3eee-42c8-839b-173967275811</Data> 
  <Data /> 
  <Data /> 
  </EventData>
  </Event>

The settings are maximum, PHYSX on, Elite Textures Trimmed are installed

Edited by Dhampir113

Share this post


Link to post
Share on other sites
dimitrius154    75

Interesting, the very same error Androdion had once, at the same general location. Must be some kind of a weather effect in the area, I guess.

By the way, do you use the original physxExt.zip, or the one from the patch?

Edited by dimitrius154

Share this post


Link to post
Share on other sites
Androdion    369

Yeah, and the same PhysX library too. Which Nvidia drivers do you have Dhampir113? I recently updated to 388.59 with PhysX 9.17.0524, do you have the same version of the drivers or an older one? Do you run any custom settings on the Nvidia Control Panel?

In all honesty my game only crashed once in 26 game hours after 1.60 saw its final release, and it was precisely in that place and with the same error report. I think I can live with that though as the next time I did the same route after a game reload nothing strange happened.

Share this post


Link to post
Share on other sites
Dhampir113    2

Nvidia drivers 388.59, PhysX 9.17.0524, physxExt.zip from the patch. NVIDIA control panel > Manage 3D settings > Global Settings > Power Management Mode > Select "Adaptive"

And here's another crash, the character was in Thylysium, after clicking on the "Save and Exit", the transparency of the minimap and the map by tab reset to default (is set to 0) after this error:

Имя сбойного приложения: sacred2.exe, версия: 2.65.2.0, метка времени: 0x4be45a9b
Имя сбойного модуля: d3d9.dll, версия: 10.0.16299.98, метка времени: 0xe2fbf0fc
Код исключения: 0xc0000005
Смещение ошибки: 0x00077d3f
Идентификатор сбойного процесса: 0x2fc0
Время запуска сбойного приложения: 0x01d3774ef6a93a33
Путь сбойного приложения: D:\Games\Steam\steamapps\common\Sacred 2 Gold\system\sacred2.exe
Путь сбойного модуля: C:\WINDOWS\SYSTEM32\d3d9.dll
Идентификатор отчета: 14f3eaf9-c52b-4d0b-a636-ed189cc85400
Полное имя сбойного пакета: 
Код приложения, связанного со сбойным пакетом: 

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2017-12-17T17:45:14.359633700Z" /> 
  <EventRecordID>3835454</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>DHAMPIR-PC</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>sacred2.exe</Data> 
  <Data>2.65.2.0</Data> 
  <Data>4be45a9b</Data> 
  <Data>d3d9.dll</Data> 
  <Data>10.0.16299.98</Data> 
  <Data>e2fbf0fc</Data> 
  <Data>c0000005</Data> 
  <Data>00077d3f</Data> 
  <Data>2fc0</Data> 
  <Data>01d3774ef6a93a33</Data> 
  <Data>D:\Games\Steam\steamapps\common\Sacred 2 Gold\system\sacred2.exe</Data> 
  <Data>C:\WINDOWS\SYSTEM32\d3d9.dll</Data> 
  <Data>14f3eaf9-c52b-4d0b-a636-ed189cc85400</Data> 
  <Data /> 
  <Data /> 
  </EventData>
  </Event>

And the game does not always start with the first click on the "Play" button on Steam, sometimes I have to terminate the running process "Sacred2.exe" through the Task Manager and then restart it. The game starts from the second or third time 

Edited by Dhampir113
the transparency of the minimap

Share this post


Link to post
Share on other sites
Androdion    369

Your driver version is the same as mine, so I suspect the PhysX crash was probably due to that. I never had a PhysX crash during the Beta testings but when it went into final stage I did update my GPU drivers so it could (should) be the cause.

If you're getting that kind of behaviour then it's probably got little to do with the patch. Are you on Windows 10 by the way? I've seen some users complaining about a similar thing on Steam, games not running properly and all.

Share this post


Link to post
Share on other sites
Dhampir113    2
7 minutes ago, Androdion said:

Are you on Windows 10

Yes, Windows 10 x64. NVIDIA PHYSX LEGACY 9.13.0604 installed too

Edited by Dhampir113

Share this post


Link to post
Share on other sites
Flix    3,148

Moved recent crash reports to this thread.

Share this post


Link to post
Share on other sites
Rogue256    8

1.60 clean install no mods

1. when xanthiar the dragon gets to 50% hp left its stops attacking happened 3 times so far with my seraphin, in bronze silver and on another toon. might be a bug on my end don't know never happened before.

2. after opening the door in the quest wet danger "Octagolamus" , I went and did the free stat point quest's that were added to cm patch, when I came back the door was locked and could not open it to kill the boss, reloaded and that did not work. what did is I presses in the water area where the boss is and she walked through the large rock. that worked after killing the boss. now the rock is gone. a glitch on my end ?

note: 40+hrs no freezing and been jumping around the map to,  

Share this post


Link to post
Share on other sites
Androdion    369

Doesn't he just start flying around like he is running away and then lands away from you? I've never seen him stop attacking, even killed him a couple of days ago.

Share this post


Link to post
Share on other sites
Flix    3,148

That flying-landing CA I believe is a bugged "Dive" attack.  Doesn't seem to do anything but is basically harmless.  Nothing changed about Xanthiar/Ordaurcil (both dragon use the identical creature entry) in CM 1.60.

Share this post


Link to post
Share on other sites
AstralLord    1

I dont know if this is a bug or not but the restored dragon in T energy fields appeared as a normal non boss creature to me, took him out in 3 or 4 hits.. xD

Share this post


Link to post
Share on other sites
Flix    3,148
33 minutes ago, AstralLord said:

I dont know if this is a bug or not but the restored dragon in T energy fields appeared as a normal non boss creature to me, took him out in 3 or 4 hits.. xD

I just checked all the scripts and everything seems in order.  He should be a powerful boss.  Bear in mind the boss cam doesn't exist anymore.  As for the 4 hit kill, what attacks were you using, and what level were you and the Dragon?

Share this post


Link to post
Share on other sites
AstralLord    1
10 hours ago, Flix said:

I just checked all the scripts and everything seems in order.  He should be a powerful boss.  Bear in mind the boss cam doesn't exist anymore.  As for the 4 hit kill, what attacks were you using, and what level were you and the Dragon?

My bad I haven't played in a while, forgot I had survival mod instaled while I was playing cm 1.50, disabled it, the dragon appeared again as a boss now.

Share this post


Link to post
Share on other sites
Flix    3,148
2 hours ago, AstralLord said:

My bad I haven't played in a while, forgot I had survival mod instaled while I was playing cm 1.50, disabled it, the dragon appeared again as a boss now.

No problem.  Seems many bug reports the last few weeks are from people using mods.  It's a relief, at least once we learn the cause, to know there's nothing wrong with the patch.

I will try to update as many old mods as is feasible for CM 1.60.

Share this post


Link to post
Share on other sites
AstralLord    1

Anyway didnt have a single bug or crash during my playthrough, graphics are all maxed, physics on, 4x AA, elite textures, patch works extremly well :)

Share this post


Link to post
Share on other sites
Dhampir113    2

I, by the way, found the reason why Sacred was launched not for the first time on Windows 10, when clicking on the "Play" button in the Steam, especially for users with different system cleaners, such as Ccleaner. The fact is that Sacred creates temporary folders in the directory C: \ Users \ username \ AppData \ Local \ Temp. The first click creates the "Ascaron Entertainment" folder, then "Sacred 2" is inside it, and the game's and configuration's cache files are created on the third time started. Those. immediately after installation, the game will start from the third time (does not apply to users with an OS other than Windows 10) or if this directory crashes, then the game will start again only the third time. In Ccleaner there is a setting - to delete Temp files, if the sacred's directory of temporary files does not exist in exceptions, this will happen. I checked it now, just deleting the entire directory. Sorry for bad English

Edited by Dhampir113
  • Thanks 1

Share this post


Link to post
Share on other sites
King Angel    66

Healing Potions Bug:

Healing potions don't stock togheter ( 20 per stack). Here is am picture 

Game Version 2.65.2 with CM Patch 1.60

Healing Bug.jpg

Share this post


Link to post
Share on other sites
AstralLord    1
13 minutes ago, King Angel said:

Healing Potions Bug:

Healing potions don't stock togheter ( 20 per stack). Here is am picture 

Game Version 2.65.2 with CM Patch 1.60

Healing Bug.jpg

Its just the first 3 potions you get from the chest when you start a new game that wont stack, not realy a big deal, try progressing through the game I think every other healing potion will stack to 99.

Share this post


Link to post
Share on other sites
Androdion    369

Yeah, potions and runes now stack to 99, and you can drop them and catch them again to "restack" them so to speak. But only potions and runes from the same difficulty level will stack though, so when one changes difficulty the new ones will be separated stacks. Hope this helps.

  • Thanks 1

Share this post


Link to post
Share on other sites
King Angel    66
2 hours ago, Androdion said:

Yeah, potions and runes now stack to 99, and you can drop them and catch them again to "restack" them so to speak. But only potions and runes from the same difficulty level will stack though, so when one changes difficulty the new ones will be separated stacks. Hope this helps.

Thanks this is helpful

  • Like 1

Share this post


Link to post
Share on other sites
JollyRogers    2

Hi @all 

First of all....many thanks to all member of the CM-Patch team to hold alive my favorit game!

Now I has to come with a issue that I see on my laptop.
After a clean instalation of Sacred 2 + I&B 2.65.1 I want to install the v160patch (and yes the game was unlocked :) )
System: Laptop i7, 8GB Ram, Win10

When I start the installer...the message down appears!
It was possible to procces the installer, but after some time the installer terminates with an error.
The game starts with CM 160 but not with all changes.
The de-installer remove the changes

On my main PC, the installation of v160 was succesful 

 

Some advice in that case:)

Thanks in advance
BR 

cm160_error.jpg

Edited by JollyRogers
  • Like 1

Share this post


Link to post
Share on other sites
King Angel    66
14 hours ago, JollyRogers said:

Hi @all 

First of all....many thanks to all member of the CM-Patch team to hold alive my favorit game!

Now I has to come with a issue that I see on my laptop.
After a clean instalation of Sacred 2 + I&B 2.65.1 I want to install the v160patch (and yes the game was unlocked :) )
System: Laptop i7, 8GB Ram, Win10

When I start the installer...the message down appears!
It was possible to procces the installer, but after some time the installer terminates with an error.
The game starts with CM 160 but not with all changes.
The de-installer remove the changes

On my main PC, the installation of v160 was succesful 

 

Some advice in that case:)

Thanks in advance
BR 

cm160_error.jpg

I have the same error :(

Share this post


Link to post
Share on other sites
12DuneLord34    14
3 hours ago, King Angel said:

I have the same error :(

 

17 hours ago, JollyRogers said:

Hi @all 

First of all....many thanks to all member of the CM-Patch team to hold alive my favorit game!

Now I has to come with a issue that I see on my laptop.
After a clean instalation of Sacred 2 + I&B 2.65.1 I want to install the v160patch (and yes the game was unlocked :) )
System: Laptop i7, 8GB Ram, Win10

When I start the installer...the message down appears!
It was possible to procces the installer, but after some time the installer terminates with an error.
The game starts with CM 160 but not with all changes.
The de-installer remove the changes

On my main PC, the installation of v160 was succesful 

 

Some advice in that case:)

Thanks in advance
BR 

cm160_error.jpg

This message is in fact not an error. It is the way, Windows tells you, that some registry entries are already there. The CM Patch 0.160 sets the two files "sacred2.exe" and "s2gs.exe" to run in Adminstrator Mode. Windows 10 itself sets these files to run in Admin Mode, then you first start Sacred2. There are some compatability tests done and Windows sets these registry entries for you. Don't ask me, why Windows can't give a proper message like: "The Registry Entries already exists." (in german this would be "Die Unterschlüssel wurden bereits erstellt." or something like this.

What do you mean by "not with all changes." What exactly does not work or does not appear? Have you any kind of memory cleaner installed? And, very important: exclude the complete Sacred 2 game folder in your anti virus. The popularity of the CM Patch may be big within the community, but we are - in fact - a very small community. And therefor, the overall usage of this specific file is very limited. To avoid your anti virus to interfere with the CM Patch, exclude the game folder from scanning. I had an issue with the CM Patch 0.150, there all text was gone due to my anti virus.

My experience was, that it is the best choice to a start a fresh character with the new CM Patch.

Share this post


Link to post
Share on other sites
JollyRogers    2

The only anti virus is win defender.

The patcher terminats with the message attached.

In fact, the physxExt.zip is not changed ... after the (not completed) patch procedure 10.210KB
...it should be after install the v160it 57KB
During deinstall v160 the message below appeares...not found graphic25.zip
Maybe this file will be installed with v160

That's why I think the patch is not completely installed.

cm160_ patch error.jpg

cm160_ patch deinstall error.jpg

Edited by JollyRogers
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×