Jump to content

Help Sacred 2 Gold (steam) don't start (startup error)


Recommended Posts

As mentioned, I've tried all solutions detailed in this topic. So, community patch, redistributables (like PhysX), running as admin and with compatibility, putting in the command lines. I also thoroughly cleaned out everything before installing with CCleaner and installed the newest drivers of my graphic card (GeForce RTX 2070, btw). So, I am really not sure, what else I can try. I tried everything that has been suggested. Twice.

Link to post
  • Replies 73
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

^ BINGO! I am currently right out of ideas. Regardless, I would keep a positive attitude and try the other suggestions above. You may even want to have a small, kindly chat with your PC and tell

Have you tried downloading the dll which shows in the error :) Something similar happened to me the first time I installed the sacred of steam ... I looked for the dll and threw it in the system folde

Interesting.....that .dll shouldn't even be getting loaded unless you are in fact running on a laptop (and my guess is with Intel Integrated Graphics), no wonder you were getting a black screen, the d

1 hour ago, jedijimi said:

Did you verify files through steam. I once learned that lesson.

Yes, I did. Again, I tried anything that has been mentioned. I actually followed the step-by-step instruction outlined by Hooyaah. I also read the suggested links on the Steam-Fora and followed their advice as well.

Link to post

Are you running Windows 10? If so, you may want to check your Windows Security settings. Go to Windows Security and access Virus and threat detection. Under Ransomware protection go to Manage ransomware protection and if your Ransomware protection is turned on (recommended) then go to Allow an app through Controlled folder access. Now, click on Add an allowed app and then look under Recently blocked apps. If you see Sacred 2 there you will need to add it to allowed apps. If this isn't your problem you may have another anti-virus/malware program or firewall blocking the game. Please let us know if this helps.

Link to post
On 11/28/2020 at 9:20 AM, Darnoc said:

As mentioned, I've tried all solutions detailed in this topic. So, community patch, redistributables (like PhysX), running as admin and with compatibility, putting in the command lines. I also thoroughly cleaned out everything before installing with CCleaner and installed the newest drivers of my graphic card (GeForce RTX 2070, btw). So, I am really not sure, what else I can try. I tried everything that has been suggested. Twice.

Game can be hard when starting up, but thankfully there's a lot of help for getting it up and running and into the partying with the gang here at Sacred!

May your gaming doors be and your Ancarian adventure begin

 

welcome to the forums!

:hugs:

gogo

 

p.s. @Hooyaah and @jedijimi thanks for the help! :superman:

Link to post
41 minutes ago, Hooyaah said:

Are you running Windows 10? If so, you may want to check your Windows Security settings. Go to Windows Security and access Virus and threat detection. Under Ransomware protection go to Manage ransomware protection and if your Ransomware protection is turned on (recommended) then go to Allow an app through Controlled folder access. Now, click on Add an allowed app and then look under Recently blocked apps. If you see Sacred 2 there you will need to add it to allowed apps. If this isn't your problem you may have another anti-virus/malware program or firewall blocking the game. Please let us know if this helps.

Hey Hooyah, thanks for the advice. Yes, I do use Windows 10, but I don't use the Windows default security, rather I have Kaspersky Internet Security (thus I can't access the ransomware protection of windows, it is off). But Kaspersky didn't block Sacred 2, I just checked. I nonetheless put it onto the list of exceptions, just in case. Didn't change the problem, though.

Link to post
46 minutes ago, gogoblender said:

Game can be hard when starting up, but thankfully there's a lot of help for getting it up and running and into the partying with the gang here at Sacred!

May your gaming doors be and your Ancarian adventure begin

 

welcome to the forums!

:hugs:

gogo

 

p.s. @Hooyaah and @jedijimi thanks for the help! :superman:

Thank you very much :D As mentioned, Sacred 1 Gold works like a charm and I am having a lot of fun with it. Playing a soaring daemon with tentacles and infernal weapons, she's great :cool::devil:

So, I really hope this problem with Sacred 2 Gold can be solved eventually. Just that you fully understand what happens:

When I start up Sacred 2, I first see the screen with the files loading. After that, the logos of the firms should appear, but instead I just land on a black screen and then I am stuck there. I can ctrl-alt-del out of it, but only to sign off or restart, going back to desktop doesn't work anymore.

Link to post

You may need to install Visual Studio (latest update). I would also advise you to install the Microsoft Visual Studio Code and Nvidia GeForce Experience and have it install the latest drivers, as it has a more complete package that will likely include the certain something that your rig is missing. Afterward you may uninstall the GeForce Experience and the rest of the drivers should remain. Reboot after each new download is installed.

Link to post
17 minutes ago, Hooyaah said:

You may need to install Visual Studio (latest update). I would also advise you to install the Microsoft Visual Studio Code and Nvidia GeForce Experience and have it install the latest drivers, as it has a more complete package that will likely include the certain something that your rig is missing. Afterward you may uninstall the GeForce Experience and the rest of the drivers should remain. Reboot after each new download is installed.

Geforce Experience was already pre-installed on my laptop, so no worries there. Anyway, installed Visual Studio and Visual Studio Code, then restarted. Didn't change anything.

Link to post

If you have used the GeForce Experience to install the latest graphics driver that should not be the issue. For some reason, more members here report issues getting the Steam version of Sacred 2 Gold to start. With Steam running in the background, try running Sacred 2 from its shortcut in the root folder directly, by right-clicking and Run As Administrator. If that doesn't work, you will need to uninstall the game and delete everything in the Sacred 2 folder. Reinstall Sacred 2 Gold in Program Files/Sacred 2 Gold. Reboot and see if the game will launch before installing the CM Patch 160. Then follow the instructions here.

Link to post

Hey all, a shame that the steam version has so much problem for Sacred 2 to launch on Windows 10. Can't you have a refund on Steam and buy it on the GoodOldGames (GOG) platform? I don't think the GOG version (the one I got instaled right now) has all these problems.

Just in case, try to rename the folder trailer (for example in trailer_old) situated in the locale\<your_language>\ folder of Sacred 2. It will then skip the intros, maybe that'll help.

Else I saw recently that putting Windows XP SP3 compatibilty mode worked for some players.

Edited by desm
Link to post
2 hours ago, Hooyaah said:

If you have used the GeForce Experience to install the latest graphics driver that should not be the issue. For some reason, more members here report issues getting the Steam version of Sacred 2 Gold to start. With Steam running in the background, try running Sacred 2 from its shortcut in the root folder directly, by right-clicking and Run As Administrator. If that doesn't work, you will need to uninstall the game and delete everything in the Sacred 2 folder. Reinstall Sacred 2 Gold in Program Files/Sacred 2 Gold. Reboot and see if the game will launch before installing the CM Patch 160. Then follow the instructions here.

Ok, tried it exactly as you suggested. But after the reinstall, when I tried to start up the game, the reaction was again exactly the same. Loading screen and then black screen. So no joy here. Thus I conclude, installing the Community Patch won't solve this problem, as it seems to be running deeper.

 

1 hour ago, desm said:

Hey all, a shame that the steam version has so much problem for Sacred 2 to launch on Windows 10. Can't you have a refund on Steam and buy it on the GoodOldGames (GOG) platform? I don't think the GOG version (the one I got instaled right now) has all these problems.

Just in case, try to rename the folder trailer (for example in trailer_old) situated in the locale\<your_language>\ folder of Sacred 2. It will then skip the intros, maybe that'll help.

Else I saw recently that putting Windows XP SP3 compatibilty mode worked for some players.

Compability mode already tried and failed. Also tried your suggested trick with the "trailer"-folder. Didn't work either. So, I am no seriously pondering to get a refund, if possible.

Link to post

Before you give up, you may want to search the Steam fora for a solution. However, when you get a refund from Steam then you will be able to get a DRM-Free copy of Sacred 2 Gold from GOG. When it's on sale, it's so inexpensive as to be criminally insane. :crazy:

Link to post
53 minutes ago, Hooyaah said:

Before you give up, you may want to search the Steam fora for a solution. However, when you get a refund from Steam then you will be able to get a DRM-Free copy of Sacred 2 Gold from GOG. When it's on sale, it's so inexpensive as to be criminally insane. :crazy:

Already got it, it was on sale and very inexpensive :cool:Anyway, if I can get the GOG-version run, I will demand a refund at steam. Just installed GOG and already run into the first problem. It seems, it didn't install PhysX properly. Retrying right now.

Link to post
4 hours ago, desm said:

Hey all, a shame that the steam version has so much problem for Sacred 2 to launch on Windows 10. Can't you have a refund on Steam and buy it on the GoodOldGames (GOG) platform? I don't think the GOG version (the one I got instaled right now) has all these problems.

Just in case, try to rename the folder trailer (for example in trailer_old) situated in the locale\<your_language>\ folder of Sacred 2. It will then skip the intros, maybe that'll help.

Else I saw recently that putting Windows XP SP3 compatibilty mode worked for some players.

 

1 hour ago, Hooyaah said:

Before you give up, you may want to search the Steam fora for a solution. However, when you get a refund from Steam then you will be able to get a DRM-Free copy of Sacred 2 Gold from GOG. When it's on sale, it's so inexpensive as to be criminally insane. :crazy:

UNhappy to report: the GOG-version got exactly the same problem as the Steam-version on my system: loading screen shows, after that only dark screen.

Link to post
7 hours ago, Darnoc said:

UNhappy to report: the GOG-version got exactly the same problem as the Steam-version on my system: loading screen shows, after that only dark screen.

Sorry to hear that.

Have you tried putting your Windows 10 for Games: Settings > Games > Game mode > On

and Developers Mode: Settings > Update and Security > Developers Space > Developer Mode > On

Also try to remove any GOG Galaxy or Steam client overlays.

Have you finally tried to install CM Patch? It can do the trick.

Good luck.

Link to post
4 hours ago, desm said:

Sorry to hear that.

Have you tried putting your Windows 10 for Games: Settings > Games > Game mode > On

and Developers Mode: Settings > Update and Security > Developers Space > Developer Mode > On

Also try to remove any GOG Galaxy or Steam client overlays.

Have you finally tried to install CM Patch? It can do the trick.

Good luck.

Tried out your recommended settings, didn't help at all. Same problem remains.

I deliberately forgoe to install the patch yet, because of the advice of Hooyah: first see, if you can get the game to run on its own and only then install the patch.

What puzzles me about the whole situation is this: I can see the setup screen with the Sacred Logo, when I try to start up the game. Even the special sacred mouse icon appears on the screen. But after the setup screen, instead of the logo of Deep Silver etc. only a black screen arrives, out of which there is no escape to desktop, but only to log out via ctrl-alt-del. This is very weird. I cannot even access the Task Manager.

Link to post
  • 3 weeks later...

Ok, guys, I finally found the solution that actually worked on another forum (World of Players, thx to Khaosmind there, who suggested it).

Copy
- d3d9.dll
- d3d9on12.dll
From
"C:\Windows\SysWOW64"
To
"...\Sacred 2 Gold\system"

After that you can start Sacred 2 via the exe without compability mode or launch options.

Link to post
4 hours ago, Darnoc said:

Ok, guys, I finally found the solution that actually worked on another forum (World of Players, thx to Khaosmind there, who suggested it).

Copy
- d3d9.dll
- d3d9on12.dll
From
"C:\Windows\SysWOW64"
To
"...\Sacred 2 Gold\system"

After that you can start Sacred 2 via the exe without compability mode or launch options.

really?

Link to post
12 hours ago, desm said:

really?

Yes. World of Players even added this advice to their FAQ on how to make the game run on Windows 10.

I mean that with full earnest: no other advice has worked for me. This is the only thing that made the game run on my system.

Link to post
26 minutes ago, Darnoc said:

This is the only thing that made the game run on my system.

Nice. This post has to be remembered. How many players came with lots of hard time getting the game to run and letting us adviceless. Enjoy the game so.

Link to post
  • 4 weeks later...
On 12/19/2020 at 5:41 PM, Darnoc said:

Ok, guys, I finally found the solution that actually worked on another forum (World of Players, thx to Khaosmind there, who suggested it).

Copy
- d3d9.dll
- d3d9on12.dll
From
"C:\Windows\SysWOW64"
To
"...\Sacred 2 Gold\system"

Thank you.

After days of trying to get Sacred 2 working on Windows 10, I find this forum and that post.

Worked first time. Very grateful.

  • Like! 1
Link to post
16 hours ago, amobofblackmen said:

Thank you.

After days of trying to get Sacred 2 working on Windows 10, I find this forum and that post.

Worked first time. Very grateful.

And a hearty welcome to DarkMatters Harold! Delighted you made your way to our little home and got that game blazing!

:)

 

gogo

Link to post
  • 2 months later...

hello I try 
Copy
- d3d9.dll
- d3d9on12.dll
From
"C:\Windows\SysWOW64"
To
"...\Sacred 2 Gold\system"

but for me not work...

pre lauch with orange words and 3 second later black screen and the program not respond...

Windows 10 HOME 
16gb ram
radeon r9 270x 
ryzen 3800x

pls help me

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...