Jump to content
occram

Help Sacred 2 Gold (steam) don't start (starup error)

Recommended Posts

occram    0

Hi

I need your help, my sacred 2 gold don't start, I tried everything,  but I always have the same message:

startup error
driver: [nvldumd.dll]
graphicscard: [NVIDIA GeForce GTX 1080]
device: [\\.\\DISPLAY1]
cDX9Base::_initDX() CreateDevice failed!
cDX9Advance::_initAdvance() initDX failed!
SacredApp::setup() setupWindow failed
App::Setup() failed

 

I tried to install Dx,Physx,cm0160 hotfix

I do not know what to do anymore HELP :)

sorry if I have a wrong place to write

Ps I have windows 10

Edited by occram

Share this post


Link to post
Share on other sites
Hooyaah    1,474
11 hours ago, occram said:

Hi

I need your help, my sacred 2 gold don't start, I tried everything,  but I always have the same message:

startup error
driver: [nvldumd.dll]
graphicscard: [NVIDIA GeForce GTX 1080]
device: [\\.\\DISPLAY1]
cDX9Base::_initDX() CreateDevice failed!
cDX9Advance::_initAdvance() initDX failed!
SacredApp::setup() setupWindow failed
App::Setup() failed

 

I tried to install Dx,Physx,cm0160 hotfix

I do not know what to do anymore HELP :)

sorry if I have a wrong place to write

Ps I have windows 10

 

Occram, did you install the CM 160 Patch? With the now updated CM Patch 160 the hot fix is unnecessary. Here is my advice:

1) Uninstall Sacred 2 Gold

2) Update your  NVIDIA driver to Version 388.71 by going to the NVIDIA website. Install GeForce Experience (optional) this has an option to update the driver and keeps you informed of regular updates.

4) Be sure that Windows 10 has installed all of the latest updates including Microsoft Net Framework

5) Reboot your PC

6) Install Sacred 2 Gold with an integrity check.

7) Reboot your PC

8) Run the CM Patch 160

9) Reboot your PC

10) De-fragment/Optimize your PC

11) Reboot your PC

The game should load properly now. If not let us know and you may want to run CPU-Z and provide more of your system info.

 

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
occram    0

Hi

Thanks for the reply, I tried everything you wrote.

 

I do not know what to do

My System:

Ryzen 5 1600

MSI GTX1080 Gaming x

16 gb ram 

Motherboard msi tomahawk b350

Windows 10 (10.0) professional 64-bit (build 16299) directX 12

Tips? 

Sigh I want play....:(

Tank you for all

Ps one last thing today I buy gog version of sacred 2 gold but I have the same result

Edited by occram

Share this post


Link to post
Share on other sites
Hooyaah    1,474

I use the GOG version of Sacred 2 Gold and have no issues, so I doubt that is the problem. Be sure you have the Microsoft NET Framework 3.5 Installed. Also it may be necessary to install Microsoft Visual Studio. First try this: Install the .NET Framework 3.5 on Windows 10.

  • Like 1

Share this post


Link to post
Share on other sites
occram    0

Then .net framework 3.5 is ok I see the guide, and I tried install microsoft visual studio but nothing.. same result :(

 

Share this post


Link to post
Share on other sites
Hooyaah    1,474

Go into the Sacred 2 Gold root folder and find the Launch Sacred 2 application. Right click on the icon and go to properties. Have the program checked under Shortcut/Advanced to "Run As Administrator." Also, in the Shortcut Target Field, after "D:\Sacred 2 Gold\system\sacred2.exe" add: -nocpubbinding -skipopenal. It should then read:  "D:\Sacred 2 Gold\system\sacred2.exe" -nocpubbinding -skipopenal

Then, also in the root folder, find s2gs.exe and have it set to "Run As Administrator" just as you did for the Sacred 2 Launch application.

Additionally, be sure that any firewall/antivirus/anti-malware programs allow Sacred 2 an exception and are not impeding its functionality. Check Windows Defender for any messages regarding blocked features or services related to Sacred 2.

 

  • Like 1

Share this post


Link to post
Share on other sites
Flix    3,152

Try it without the patch or any other alterations first.  Does it run then?

  • Like 1

Share this post


Link to post
Share on other sites
Ayylena    3

Try running in compatibility mode, I used Windows XP Service pack 3. But I think my main issue was Physx. I hope you can get it to work!

  • Like 1

Share this post


Link to post
Share on other sites
dimitrius154    75

Hmm, I would advise doing the following: install a complete DirectX 9.0c end-user runtime. After that, perform a clean Video Driver installation(not an update).

Edited by dimitrius154
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Hooyaah    1,474

Okay, Occram, we are not giving up on you. Here is a link to download at Microsoft.com the DirectX  End User Runtime

If your issue is still unresolved there are a few other discussions at Steam of which you may not be aware so I picked a couple that look promising. It seems that others are having the same or similar problems after the recent Windows 10 updates.

http://steamcommunity.com/app/225640/discussions/0/846940248321885764/

http://steamcommunity.com/app/225640/discussions/0/846940248918660409/

  • Thanks 1

Share this post


Link to post
Share on other sites
Ayylena    3
5 hours ago, Hooyaah said:

Okay, Occram, we are not giving up on you. Here is a link to download at Microsoft.com the DirectX  End User Runtime

If your issue is still unresolved there are a few other discussions at Steam of which you may not be aware so I picked a couple that look promising. It seems that others are having the same or similar problems after the recent Windows 10 updates.

http://steamcommunity.com/app/225640/discussions/0/846940248321885764/

http://steamcommunity.com/app/225640/discussions/0/846940248918660409/

I actually used the first link's instructions and it worked for me. I would advise reinstalling and trying that because it worked perfectly for me after I did this part

"Find your Sacred 2 Gold Folder in steam.. you should open like this Computer > Local Disk (C:) > Program Files (x86) > Steam > SteamApps > common > Sacred 2 Gold > redist > PhysX > now just run the physx installer, install it and then the game should run fine..."

Also, go to steam, right click Sacred 2 Gold and hit properties then go to the Local Files tab and hit "verify integrity of game files" I'm not sure if this is an absolute fix but it IS one of the steps I did to get my game to work.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Anathriel    3

So I am using Win10, Steam, Sacred 2 Gold, CM 1.6, Elite Textures and I got it to work with the "run as admin" - option in combination with the compatibility mode set to Win XP SP 3 and the starting params like mentioned above and I could play a little. I found this guide at steam forum very useful for my issues I had before: http://steamcommunity.com/sharedfiles/filedetails/?id=166938930

For some reasons which I don't know, it might be an Windows Update, this settings did not work any more. The only way to get the game then running was to start already Steam with administrator rights and suddenly the game worked like before. Hope that helps!

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×