Jump to content
ThirstOfBlood

Problems editing the global.res

Recommended Posts

I recently updated the game to cm patch 1.60 and installed the s2ee as well. 

I had the previous version of enchanted spells and I had some personal tweaks for some of them which requiremed me to edit the global.res file. 

I had no problem with the spells.txt file but I cant seem to be able to edit the global.res file

What I did was:

1. Run s2rw in the locale en folder. 

2. Decode and get a notepad with all in game texts

3. Replaced in notepad whatever needed replacement for my tweaks

4. Encode with the "all texts" option.

5. Make a backup and delete the old global.res file, renamed the new one as global.res

 

However when I enter the game none of my changes appear and if I decode the global.res again its just like the original one. 

 

Is there something im doing wrong?

NOTE: I found one of my old edited global.res ( the one with new EN etc in its name ) and it had a + sign ( unlike the one I did today ). I dont know what that means.

 

Beside that, I tried to copy the classic icons from the first enchanted spells mod and they dont change at all. 

 

Id appreciate any help. Thx. 

 

EDIT: Managed to solve the global.res problem after checking all the posts about it again. I didnt run the encoding from the system folder. 

Still trying to change the icons with no result.

 

EDIT 2: unlike in the first version of enchanted spells, the spell and runes icons were in a zip. Didnt notice that in the first place. Everything is solved now. 

Edited by ThirstOfBlood
  • Like! 1
  • Thanks! 1

Share this post


Link to post
Share on other sites

Great to see you managed to work this out for yourself.

It's also great seeing you posted what you did wrong here for others to learn from / follow if they make similar mistakes in future.

  • Like! 1

Share this post


Link to post
Share on other sites

im trying that now with no results :x
putting the global.res in the systemfolder

decoding everything, editing and saving the globalDe_texts.txt, encoding everything

replacing the old gobal.res in locale\De with the new global.res I made in the systemfolder

then I decode the new global.res to check and my changes are gone

Share this post


Link to post
Share on other sites
Posted (edited)
On 1/12/2018 at 5:17 PM, ThirstOfBlood said:

EDIT: Managed to solve the global.res problem after checking all the posts about it again. I didnt run the encoding from the system folder. 

 

 

How do I "run the encoding from the system folder"
Also I am not able to execute by "pront comand"

 

P.S: In the pront always this message appears ... "is not recognized as an internal or external command, an operable program or a batch file."

Edited by vagnerhammer

Share this post


Link to post
Share on other sites

People!!! Help me!!!!
When I open "S2rw.v1.7" by cmd it gives "access denied" ...
Help!!!!Caperrturar.thumb.PNG.5074243bfb8e2afeb6379b763945e908.PNG

Share this post


Link to post
Share on other sites

This looks like a Windows permissions issue.  It looks like you have this program installed in Windows\System32 - this is not the correct location and could explain why you've had so many issues.  That folder is a highly protected folder in Windows.

The Program Files folder can also be protected and cause numerous issues with mods.

You need to have S2rw in your Sacred install folder, inside the sub-folder called "system"

I recommend to always install games somewhere like "C:\" or in a custom folder like C:\Games

  • Thanks! 1

Share this post


Link to post
Share on other sites

Actually, it looks like he's trying to run the tool in Windows/System32, whereas the game is installed in C;\Program files\etc...

Hopefully following the below instructions is sufficient to help him out.

3 hours ago, Flix said:

You need to have S2rw in your Sacred install folder, inside the sub-folder called "system" 

 

  • Thanks! 1

Share this post


Link to post
Share on other sites

Do you believe that the problem continues :) lolololC555apturar.thumb.PNG.7c8036f070a073994c6e9e298b42e2d7.PNG

 

Note that I installed it now in C: game

 

C456apturar.thumb.PNG.aeaed437647e1a2e10b8cdd58d19a728.PNG

 

I am looking for a job that will enable me to ...

 

Capt45645urar.thumb.jpg.0dde772df120207d936aace576656122.jpg

 

The only way to encode the edited "txt" is by cmd :)

Share this post


Link to post
Share on other sites

The progress was that I was able to solve all the errors that S2rw.v1.7 presented to me ...

Ca46541pturar.thumb.PNG.cbf51e12ada88dab813271f04de939ab.PNG

Share this post


Link to post
Share on other sites

Solution

In Windows 10 we have to activate developer mode to solve constraints.

 

what-is-developer-mode-in-windows-10-2.png.b7c110eab2d536458739784036bf9880.png

 

 

 

  • Like! 1

Share this post


Link to post
Share on other sites

Yes, in Win10 64 at least you will get that message because the OS by default runs userspace applications in a restricted permission mode, this is a good thing, but a PITA at the same time to remember to turn it back off after you're done with things like Visual Studio.

  • Like! 1

Share this post


Link to post
Share on other sites
On 3/2/2019 at 1:29 AM, Flix said:

This looks like a Windows permissions issue.  It looks like you have this program installed in Windows\System32 - this is not the correct location and could explain why you've had so many issues.  That folder is a highly protected folder in Windows.

Flix ... You're absolutely right. Yesterday I arrived in the swamp dragon with the "Dragon Mage" ... It worked perfectly.
On my machine I now have two sacred installations ... one in the "Program Files" and another in "C: / Games" as you have instructed. I immediately checked the "Program Files" installation and the problem still exists in it.  So even the issues of "dragon do not attack" ended up being settled by the issue of the permissions.
I ask pardon ...
Immense gratitude for the help...:bow:

  • Like! 1

Share this post


Link to post
Share on other sites
12 hours ago, thejynxed said:

Yes, in Win10 64 at least you will get that message because the OS by default runs userspace applications in a restricted permission mode, this is a good thing, but a PITA at the same time to remember to turn it back off after you're done with things like Visual Studio.

You went to the exact point !!!
Father Bill and his novelties lololol

  • Like! 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×