Jump to content

Recommended Posts

John999    5

Hello. Is there a way to reduce the lag in Griffinborough? It's quite extreme on my PC, like every 1 second in the more populated areas of the town.

Share this post


Link to post
Share on other sites
Hooyaah    1,468

It would help to know which version of the game you running. Unless you are running the trimmed elite textures and have installed the CM 160 Patch there shouldn't be a problem unless it's related to your system. More specifics about your rig and its OS could help with a bit of troubleshooting.

Share this post


Link to post
Share on other sites
lujate    440

On PS3, it was bordering on unplayable, but I never saw any issues on PC.

Share this post


Link to post
Share on other sites
John999    5

GTX 1050 2GB, A10-7800, 8GB RAM, Win10 64bit. I'm about to switch the A10 7800 for a Ryzen 3 1300X, but I don't think it will be any different. Playing vanilla GOG version.

Share this post


Link to post
Share on other sites
Hooyaah    1,468

I don't believe that there is anything regarding your system that would create an issue. Let me know if I understand correctly. Do you mean that you are playing the original, "vanilla" Sacred 2, not the Gold version? If so, then the community patch will be of no help. If however, it's the Gold version, then I would recommend installing it because it would fix the issue that you are reported as well as many others, including the dreadful game crash (memory leak).

Otherwise, I haven't played the original vanilla version in so long that I cannot offer any suggestions other than to make certain that you check this thread. There are links to drivers and other resources there that Sacred 2 needs to run properly.

Share this post


Link to post
Share on other sites
John999    5

Sorry for confusion, I play Sacred 2 Gold vanilla (as in unmodded). I don't experience crashes other than when closing down the game, and I'd like to try some suggestions before having to install the community patch because as said I like my games unmodded. It looks like it also changes the game menu and I prefer the old one.

Edited by John999

Share this post


Link to post
Share on other sites
Androdion    339

You can use the trimmed elite textures even without the CM Patch, though with it you can be mostly bug free. There is lag in Griffinborough with elite textures turned on, but with the trimmed version it runs mostly smooth.

And Flix also released a main screen mod that can let you customize it to your liking. Sorry for not providing any links, I'm on my phone. Check the download section.

  • Thanks 2

Share this post


Link to post
Share on other sites
Hooyaah    1,468

A member recently reported in this thread that they were getting better stability benefits even after disabling the CM Patch 160. You may want to check it out.

The link to the opening screens that my friend, Androdion is referring follow:

Fallen Angel Main Menu 1.1.0

I particularly appreciate the Demo Version. With its dynamic lighting, it is startlingly realistic and astonishingly aesthetically pleasing.

 

Share this post


Link to post
Share on other sites
Flix    3,121

If you don't like the CM Interface, what you're actually looking for is this package:

Given that I always felt the interface was an appallingly trivial reason to avoid a patch or mod, I simply compiled all known interfaces so the player could choose whichever they preferred.  They can be installed over any version of the game.

  • Like 1

Share this post


Link to post
Share on other sites
John999    5

Thanks all for the suggestions. Do you think reinstalling the game (along with its stuff like VCredist) might solve the problem? I also notice shadows flickering, especially in Griffinborough.

Share this post


Link to post
Share on other sites
John999    5

Yeah they're kind of like flickering with with a yellow-ish color, I'll do the reinstall after I upgrade the CPU and report back here.

Share this post


Link to post
Share on other sites
John999    5

So apparently enabling VSync fixed my lag issues. The game is now very smooth. Is it safe to use VSync? No crashes or anything reported by users? Edit: Also do you guys know if it is possible to configure the camera in optionsCustom.txt so that it is third-person-like? If yes could you tell me what do I need to put in that .txt file? Thanks.

Edited by John999

Share this post


Link to post
Share on other sites
rm3000    81

You could have a look at 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Hooyaah    1,468
3 hours ago, John999 said:

So apparently enabling VSync fixed my lag issues. The game is now very smooth. Is it safe to use VSync? No crashes or anything reported by users? Thanks.

VSync is fine to run, checking your rigs specs. There is a lot of information regarding camera settings in the thread rm300 linked to and the latter part should have what you are looking for concerning a third-person view. After all there are so many ways to alter the camera settings that the possibilities are virtually endless. There is also the Reduced Fog Mod if you wish to see further into the distance.

Share this post


Link to post
Share on other sites
John999    5

Great, it's either lag without VSync, or input lag with VSync.

Share this post


Link to post
Share on other sites
John999    5

Can someone else please try using VSync in the game and tell me if they notice any input lag?

Share this post


Link to post
Share on other sites
Androdion    339

I play with V-Sync on all the time and never had any issues like the ones you report. I also have "hardware mouse cursor" active, not sure if it makes any difference about it or not. But it does seem like it's a problem directly related to your PC.

Share this post


Link to post
Share on other sites
John999    5
18 minutes ago, Androdion said:

I play with V-Sync on all the time and never had any issues like the ones you report. I also have "hardware mouse cursor" active, not sure if it makes any difference about it or not. But it does seem like it's a problem directly related to your PC.

Yeah I'm probably just imagining things due to reading about VSync, and VSync related latency should be the same in a game on different PCs.

Share this post


Link to post
Share on other sites
Androdion    339

I guess it could vary with different mouse models and their respective drivers/control centres. I have a high end Logitech mouse with up-to-date drivers, but I remember playing with my old G5 model and not having issues as well.

I'd still put my money on third party programs causing your issues.

Share this post


Link to post
Share on other sites
Hooyaah    1,468

I agree that third-party programs such as an antivirus program is the most likely reason that your frame-rate suffers so. Avast antivirus uses a vast amount of resources as do others of its ilk. You should check to see what programs are checked to start when your computer boots. A simple way to check is to type in the command prompt in Search, msconfig that will pull up the menu that you see below. Be aware that Avast will not allow itself to be disabled.

Go to the Services tab and place a tick mark "check" to Hide All Microsoft Services as you do not want to accidentally disable vital system services.

Now you will see other Services that start when Windows opens. You can determine any services that do not need to run automatically. After all, these services may still be opened and allowed to run manually at your command. So, uncheck any applications that you deem superfluous and then reboot your computer.

Another thing that you may do to speed up your computer: Install and run DisKMax. Be aware that this program deletes Windows Temp files and Sacred 2 will require three launch attempts the first time after using it. Then, until you use it again, the game will launch normally the first time. DiskMax is freeware and safe for Solid State Drives. As with all programs, I recommend downloading it from the author's site.

One more suggestion, if you are still having a problem with game-lag is to disable shadows or refrain from using high settings. When shadows are set to high it takes uses a lot of system resources and after lowering the settings you may not even notice the difference.

 

 

msconfig.PNG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×