Jump to content
hazer

sacred 2 problem - almost unplayable from stuttering and lag

Recommended Posts

yo guys, sacred 2 is almost unplayable for me.

the stuttering is very extreme, seems like its lagging while loading textures with each step I take.

I srsly tried every damn fix on these forums, steam and gog, and nothing is helping.

Im running the gog Sacred 2 gold version with the latest community patch.

Ofc I tried changing through all kinds of settings but the settings dont have any impact on the game lagging. It doesnt matter if I play with everything set to high or low.

Maybe my computer is too bad, but everywhere I check, ppl tell me I should be able to run the game smooth with my hardware.

My Pc:

Nvidia Gtx 550ti

AMD FX4100 @ 3,6ghz

Win 7 64 Bit

 

Share this post


Link to post
Share on other sites

Hello Hazer, your graphic card maybe is a bit low, but the first thing that comes to my mind is to check that it's your GPU that is handling PhysX and not your CPU; to check, go to the Nvidia Control Panel, Configure Surround and PhysX and check that PhysX is on Autoselection (recommanded). Else I don't know.

  • Thanks! 1

Share this post


Link to post
Share on other sites

Another thing you may want to try, if you're using the GOG Galaxy client, is to disable its overlay in the parameters or try running Sacred 2 directly by double-clicking sacred2.exe that you will find in C:\GOG Games\Sacred 2 Gold\system (by default). Good luck.

  • Thanks! 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×