Jump to content
quartrez

Teleporters for the ports in the GOG version?

Recommended Posts

Posted (edited)

Hello,

here is the situation... About a week ago, I bought Sacred 2 on Steam. I then installed the Community Patch version 1.60 and since I've installed that patch, I've had the ability to teleport to all areas that were ports (christmas island and the crystal land thing, among others) as if they were any other teleporter.

However, this evening I bought the game on GOG at a discount to not have DRM. So I made a copy of my saved files just in case, uninstalled the Steam version, installed the GOG version, installed the community patch on the GOG version, copied the saved files in the correct folder again, and... Now when I try to teleport by clicking on ports, it doesn't do anything. I tried uninstalling the CRM and reinstalling it, just in case it would do something to the saved files but alas, this yields the same issue.

Could someone tell me why it does that? And possibly how to remedy to the situation :)

Thank you!

Edited by quartrez
  • Like 1

Share this post


Link to post
Share on other sites
On 6/10/2018 at 2:21 AM, quartrez said:

Hello,

here is the situation... About a week ago, I bought Sacred 2 on Steam. I then installed the Community Patch version 1.60 and since I've installed that patch, I've had the ability to teleport to all areas that were ports (christmas island and the crystal land thing, among others) as if they were any other teleporter.

However, this evening I bought the game on GOG at a discount to not have DRM. So I made a copy of my saved files just in case, uninstalled the Steam version, installed the GOG version, installed the community patch on the GOG version, copied the saved files in the correct folder again, and... Now when I try to teleport by clicking on ports, it doesn't do anything. I tried uninstalling the CRM and reinstalling it, just in case it would do something to the saved files but alas, this yields the same issue.

Could someone tell me why it does that? And possibly how to remedy to the situation :)

Thank you!

Welcome to DarkMatters, quartrez! Here's a bump to see if anyone who can help has some info for you.  Happy to see you making your way over to the boards!

:)

 

gogo

Share this post


Link to post
Share on other sites

All I can say is that you can only teleport to ports by clicking on the map since CM Patch 1.60, so either something went wrong with the game's installation or the patch's. I'd recommend a clean reinstall with removal of all local files and reg keys prior to installing whichever version of the game plus 1.60 on top of it.

  • Thanks 2

Share this post


Link to post
Share on other sites
Posted (edited)

I removed the CM patch, uninstalled the game completely, reinstalled the game, reinstalled the patch and the teleporters for ports are now working again! Thank you :)

Edited by quartrez

Share this post


Link to post
Share on other sites

And a mighty welcome to DarkMatters, quartrez!

:dance:

 

gogo

Share this post


Link to post
Share on other sites

Yeah, the GOG version is the Bee's Knees IMO. No DRM, no internet connection, and optimized for post-Vista OS's.. :)

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×