Jump to content
Countdown To Christmas!
 

From the Sacred 2 Christmas Island Soundtrack
Click to Open Player!
 
RaZKaLz

Need help with PhysX error

Recommended Posts

Hi, a friend and I decided to play Sacred 2 again after so many years and when I tried to launch the game this error kept poping up:

driver:[aticfx32.dll]
graphicscard: [Radeon RX 580 Series]
device: [\\.\DISPLAY69]
cPhysics::init - NxCreatePhysicsSDK failed
SacredApp::setupEngine() physics init failed
SacredApp::setup() setupEngine faiiled!
App::Setup() failed!

I did a lot of things to try to fix this but still can't play the game, any help would be appreciated.

Thank you.

  • Like 1

Share this post


Link to post
Share on other sites

It would be best to do a clean, fresh reinstall of Sacred 2 and it is important to do so before adding any modifications. Unless you have a NVIDIA GPU or a separate unit for processing PhysX, your rig will not process PhysX effects, so you may go into the Graphics Options and remove the tic-mark. Because there may be other issues related to missing drivers and the like, you might be best off following the instructions below:

First, ensure that you have Microsoft NET Framework 3.5 Installed. Also it may be necessary to install Microsoft Visual Studio. Here is a link to download at Microsoft.com a current version of DirectX.

1) Uninstall Sacred 2 Gold

2) Update your GPU's graphics driver.

4) Be sure that your version of Windows has installed all of the latest updates including Microsoft Net Framework

5) Reboot your PC

6) Install Sacred 2 Gold with an integrity check.

7) Reboot your PC

8) Run the CM Patch 160

9) Reboot your PC

10) De-fragment/Optimize your PC

11) Reboot your PC

12) Finally, be sure that any firewall/antivirus/anti-malware programs allow Sacred 2 an exception and are not impeding its functionality. Check Windows Defender for any messages regarding blocked features or services related to Sacred 2.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I'm getting the same error as RaZKaLz, same circumstances coming back to play game again after many months off.  I followed the directions of the above fix but ran into a roadblock at the CM Patch stage.  When I go to run cm-enable, I get a weird error message: it's claiming I don't have Sacred 2 in the registry and it asks me to point to the root directory manually.  When I do, cm-enable tells me I don't have Sacred 2 installed at all, or have the wrong version installed.

Some Win10 update must have borked something pretty hard, since I played with the cm patch fine for many months earlier in the year.

Share this post


Link to post
Share on other sites

Try This: Go into the Sacred 2 Gold root folder and find the Launch Sacred 2 application. Right click on the icon and go to properties. Have the program checked under Shortcut/Advanced to "Run As Administrator." Also, in the Shortcut Target Field, after "D:\Sacred 2 Gold\system\sacred2.exe" add: -nocpubbinding -skipopenal. It should then read:  "D:\Sacred 2 Gold\system\sacred2.exe" -nocpubbinding -skipopenal

Then, also in the root folder, find s2gs.exe and have it set to "Run As Administrator" just as you did for the Sacred 2 Launch application.

  • Thanks 1

Share this post


Link to post
Share on other sites

Here's a screenshot of me trying to edit the sacred2 exe.  No shortcut tab, no option to mess with shortcut target field.  I can make a shortcut out of it and then do those things, but I assume that's not the ticket.  Is this because it's a Steam install?  In Compatibility tab I do have both files set to run as admin, although that line is grayed-out.

Spoiler

image.thumb.png.3ec19c3b464ba12584dc589c88fa0d2a.png

EDIT: Ah, wait, progress.  I checked and unchecked the run as admin options in compatibility tab and was able to run CM-enable.  I did get an error that one dll could not be deleted but I'll go ahead with the steps above and see if I can get success now.

EDIT 2: Still no luck, still same error message as OP.  Never did find solution to shortcut target field problem in ss.

Edited by ralspaugh
not as smart as I thought I was

Share this post


Link to post
Share on other sites

I have not had any issues playing the GOG version of Sacred 2. However, there are a few members here that have reported similar problems with the Steam version. I hope that this helps.

Here is a thread with a similar complaint that may help:

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now