Jump to content
DarkMatters Celebrates
19 Years of Wyntertyde in Ancaria

From the Sacred 2 Christmas Island Soundtrack
Click to Open Player!


Character permanently paralyzed

Recommended Posts

Have you fixed the problem yet? Unfrozen?

It is not fixed. I just had to avoid being hit.

Link to comment

How did you manage to re-move the character?

Sorry, I misunderstood the question. Reloading the game always cured the paralysis.

Link to comment
Actually no, in SP it is possible to take your mount underground. When the game starts, you will always have your mount beside you. Since SP allows you to start underground, a viola, you have your mount underground.


I know that I to reload a couple of times to the Monolith in the Carnach Cave. I just cannot remember if I used my mount.

A HA! :smart:


For, like, ever, I've sworn that I had a mount underground at times... and I figured that was just a console glitch. Since the only way to start underground on console is via the monoliths, and I don't usually stop in the dragon/carnach caves on a campaign run... nor do I ever wander around down there "for fun" so I was really kicking myself trying to remember how the heck I got my mount underground.


I knew I wasn't crazy (I swear I'm not)... thank you!

Link to comment

My psych bs does not qualify me to diagnose sane or friggin crazy, but in this case I can say you are not mistaken. :biggrin:

Link to comment

I've been having this issue a lot tonight,actually on 2 characters but mainly a Seraphim.Basically can't move my character either with the mouse or keyboard,I can move items about and press f8 to teleport back to town but that is it.It was happening in the swamps surrounded by Werewolves and Spiders while using Pelting strikes+Hallowed Restoration in a combo.

Link to comment

Same. I've crashed on DM, and it doesn't let me teleport to any town.

I have been running a DM with the CM patch recently. It has been incredibly flaky, but I have never had this problem. Does it allow you to save and exit the game?

Link to comment

Same problem as before trying to fight the Gar' Colossus. This time with a TG on his Mobiculum.

Link to comment

Same problem as before trying to fight the Gar' Colossus. This time with a TG on his Mobiculum.


Okay Thanks for giving additional info on toons that have it too. We are making slow progress on cleaning the player characters models up. Hopefully this will help get rid of this problem.


@Kavlor: Was your seraphim on a mount at the time it happened or was she standing on her own feet? (We might have to throw in the mounts as well for cleanup if this adds to the problem.)

Link to comment

Same TG, same problem. This time on foot versus the Garganthropod.

Link to comment

My Dryad has experienced movement lock a few times in the last few weeks. Mostly underneath Seraphim Island. I tried to use Forest Flight to break the movement lock, but that didn't work. FF worked, but Dryad still was locked. I tried various CAs... and eventually she unlocked.


I was wondering if stack overflow was causing corruption of the char status. The dryad was running through the lower levels ignoring the monsters (balance.txt set with low monster damge: 10% of normal). Stack overflow could occur from too many monsters spawned in a short period of time.


I wondered if it isn't stun lock, but rather a hybrid status of the game thinking you're in shopping (or sign reading) mode. Ending a merchant visit or reading a sign could end the lock (or any other valid end).


Any thoughts?

Link to comment

Not exactly sure what is causing this sort of thing - but... I know the CM Patch guys have been working on a fix for some similar issues - mostly having to do with the Crystal region. The crystals up there will lock an Inquisitor or TG hard when they 'explode' - the only option is to teleport to safety and reload the game. it had to do with animations...


This may be related somehow. There's nothing I can think of down there that will root you (except the Dryad, of course - but then again, why would she root herself with Tangling Vines?)

Link to comment

My daughter reports that using a god power breaks the paralyze at Boss fights. Has yet to be confirmed. if yes I will edit spells.txt and reduce cooldown of forens to 1 minute and reduce Forens' chance to reflect to something small like 10% to balance it.

My theory is that the god powers are something special which force a restart of the character after the animation?

  • Like! 1
Link to comment

I've used God Powers to successfully end the mysterious paralysis. It's about the only thing that works. I had a problem for a while where my Temple Guardian would freeze in mid-air while using Propelled Levitation (only when using certain weapons), just hanging there unable to do anything. Casting Will-o-Wisp always freed me from it. It's also freed me from the Crystal Plane paralysis.

Link to comment

Okay I take this as a yes: God powers break this paralysis. I will change my spells.txt like this:

mgr.defineSpell( "gott_philosophie_schutzschild", {
	eiStateName = "cSpellCast",
	fxTypeSpell = "FX_GS_SCHUTZSCHILD",
	fxTypeCastSpecial = "FX_GS_SCHUTZSCHILD_C",
	duration = 10.000000,
	animType = "ANIM_TYPE_SM19",
	animTypeApproach = "ANIM_TYPE_INVALID",
	animTypeRide = "ANIM_TYPE_RIDESM01-HORSE",
	animTypeSpecial = "ANIM_TYPE_RIDESM19-SPECIAL",
	causesSpellDamage = 1,
	tokens = {
		entry0 = {"et_duration_sec", 1500, 0, 0, 8 },
		entry1 = {"et_chance_reflect_spell", 87, 10, 0, 41 },
		entry2 = {"et_chance_reflect_CC", 87, 10, 0, 41 },
		entry3 = {"et_chance_reflect_missile", 87, 10, 0, 41 },
		entry4 = {"et_chance_reflect_root", 87, 10, 0, 41 },
		entry5 = {"et_chance_reflect_stun", 87, 10, 0, 41 },
	fightDistance = 0.000000,
	aspect = "EA_GOD_ANY",
	cooldown = 60.000000,
	soundProfile = 0,
	cost_level = 0,
	cost_base = 0,
	focus_skill_name = "skill_devotion",
	lore_skill_name = "skill_devotion",
	spellClass = "cSpellGsSchutzschild",
	spellcontroltype = "eCAtype_b_boost_self",
	sorting_rank = 0,

it should reduce all reflects to just 10% of the normal but reduces all the cooldown to just 60seconds.

Link to comment

Have no idea if anyone was interested in more information.  I've experienced 3 freeze ups like this on my new Shadow Warrior using Demonic Blow and Scything Sweep in a combo and I am always stuck while surrounded by enemies, so it becomes a frantic affair to teleport myself out once the confusion sets in.  Terrain probably plays a major factor, as it's after an animation that moves him over to a different target/angle when the 2nd combo begins.  Also have combat execution speed at 100% atm.  Was using a polearm.  Trying a warhammer out for a bit.

  • Like! 1
Link to comment

Not knowing which enemies you were fighting but groups where each member has a stunning attack can cause something which looks like a permanent paralyzis but isn't one?

Link to comment
On 11/6/2019 at 1:55 AM, chattius said:

Not knowing which enemies you were fighting but groups where each member has a stunning attack can cause something which looks like a permanent paralyzis but isn't one?

Nah, it definitely was paralysis, as you could potion yourself indefinitely and still not be able to move.  Or even gate yourself to the nearest portal to escape death, but still be paralyzed there in town while not being subject to any stun attack.  

Anyway, I have played for another 7 hours and have yet to experience the paralysis again.  I experienced a number of changes, but others will have to confirm if they see results as well.  

1) I disabled hardware mouse cursor in the menu settings.  2) I finally chose a weapon specialization skill, which elevated my base attack speed dramatically.  Went back to polearms, as I experienced the same bug with the warhammer.  From time to time the same 3 skill combo (was only 2 skill combo before) often fails to complete beyond the first skill, but I never see a paralysis again. (edit: remembered a nice trick with holding Ctrl and right-click will help every skill in the combo to activate most of the time)  3) One time (before these other changes) I was able to get out of it by deactivating the active buff (Grim Resilience) and leaping out of it with Belligerent Vault.  

I am playing with the CM 160 patch, extra textures resources, the font patch, fog mod, and camera tweaks.  And can anyone tell me how to edit a previous post?

Edited by Zematus737
Link to comment
On 11/9/2019 at 9:11 AM, Zematus737 said:

  And can anyone tell me how to edit a previous post?


15 hours ago, Androdion said:

I think you can only edit after your fifth post. Security measures on the boards.

What Androdion said about fifth post and security is right, but I have moved your status to a member, you should have no problems with editing your posts

Welcome to DarkMatters!




Link to comment


I experience the same bug a lot, and it becomes incredible annoying. I did some testing in areas where this bug occurs most frequently, and I have an idea why I experience it so often, but I need help to confirm it / advice to solve it.

My setup:
CM-Patch v1.60 + S2EE 3.0 (Core + Alternate Spells + Music and Portraits)

My char:
Dryad level 80, focused on Capricious Hunter
Buffs: Sinister Predator + Ancient Bark
Combo: Ravaged Impact + Darting Assault

Mod. Points:
Ravaged Impact: Perforate - Breach - Blast
Darting Assault: Reload - Throwback - Pierce


Testing setup:
Bug occurs most frequently when fighting in Orc region between Entruag and Blade Fields (lot of Trolls).

  • Fighting with mentioned combo (including Darting Assault) - Bug occurs <15 minutes.
  • Fighting with no combo but only with Ravaged Impact - No bug occurs over period of 40 minutes.

Darting Assault's modification point Throwback gets reflected sometimes (I don't even know if this is possible), leading to knockback / throwback of char, leading to the bug of being permanently paralyzed.

Possible solutions:

  1. Editing my char to use Wounding instead of Throwback as modification points. (Easy but temporary solution)
  2. Editing all opponents' chance of reflecting knockback to 0. (Do opponents have such skill?)
  3. Finding the source of bug in the game's core files that leads to this bug. (Probably not achievable)


Open questions:

  1. Would someone experienced give their opinion regarding my assumption?
  2. Would someone confirm the tested behaviour by repeating the test themselves?
  3. Do enemies have a "Chance to reflect knockback"? (I can't find it in the Wiki) Or is it part of "Chance to reflect Combat Art" or "Chance to reflect Ranged Damage"?
  4. If "Chance to reflect knockback" exist for enemies, what is this entry called, so I can change it?
  5. What enemies have a high chance to reflect Knockback / Combat Art / Ranged Damage, in order to test it sufficiently?

(Of course I can figure out some questions myself by reading through all the files and learning how they work, but why starting from scratch if I can ask some experienced modders)


Thanks you in advance.


  • Like! 1
Link to comment


There is a "Block Knockback" bonus but no Reflect Knockback.  Also, although there are "Reflect Ranged"  and "Reflect Spells" item/spell modifiers, they are not assigned to any creatures.

The only way enemies would gain Reflection of Ranged/Spells would be through a buff spell.  "enemy_shield_spikeshield" is used by some elite turtles and grants Melee/Ranged reflection. But that's the only such enemies.

Therefore if enemies are reflecting your own knockback against you, it must be piggybacking on the "Reflect Melee" bonus.  This doesn't really make sense though because Darting Assault should register as a weapon attack due to having the "causesSpellDamage = 0," flag, not to mention use of a ranged weapon should not trigger melee reflection.

In creatures.txt you could check any enemies that have "Reflect Melee", like so:

mgr.addCreatureBonus( 281, { bonus = 635, intensity = 300,   })

Reflect Melee bonus is 635 and 281 is the creature ID .  There's around 35 enemies or so with this bonus in EE.

One final note is that you may want to update to EE 3.1 to experience more bug fixes.

  • Thanks! 1
Link to comment

Putting in my experience with this bug:

1) Randomly unable to move (not even NPCs move) when loading the game.

 - solution: Use the save key F7, ALT+F4 and load the game again but FIRST check your task manager and make sure all instances of sacred2client and sacred2server are killed. I've had it happen multiple times that several instances have been running and it increases the likelihood of non-responsiveness and adversely impacts performance (especially loading times). Seems like the game often fails to properly close the client. Killing all the extra instances solved this bug for me every single time and would explain why PC restarts usually helped in this situation (because it removed the extra instances).


2) In-combat paralysis. Happens to me on my Shadow Warrior from time to time if I spam a ranged combo too much. Clicking extremely rapidly with low regen time and regen per-hit seems like it can simply overload the game which can't handle the input/animation/whatever interactions and simply freezes your character. It's seemingly random, because it looks like it's related to timings. As if if the next attack were to target an enemy, but it died at the exact moment the attack initiated (a projectile you fired before just killed it at that exact moment), it might lose the target and sometimes fail to acquire another, which seems to lead to the freeze. The likelihood also seems to go up the higher your attack/execution speed is or if you get stunned mid-combo. This happened to me dozens of times already, and it's always been when performing a combo with ranged attacks (my specific one is Frenzied Rampage - Demonic Blow - Spectral Hand). As far as I can tell, it has nothing to do with reflection at all. This can be easily tested by using ranged Scything Sweep against turtles or Nimonuil or Garganthropod (who reflect ranged attacks). The Knockback does not get reflected.

When I stopped spamming the combo by constantly mashing the button and instead just reusing it when it's ready (just wait until the animation of the final attack goes off or first interrupt the combo by moving), I get the freezing only very rarely. But it might be more pronounced for the Dryad since Blowguns are hitscan. But my advice is to be more methodical about ability usage.

Funnily enough, the first time I encountered it was the same as in Furian's post from 2011. When I fought the Poison Lord.

Edited by idbeholdME
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...