Jump to content

Sacred Underworld install on Vista, Windows 7, 32bit, 64bit

Recommended Posts

Well, no luck even finding a working link to patch 1.8.26, or any other patches!


Same thing looking for an Underworld download... well probably not the biggest surprise with the demise of Ascaron.



Link to comment

Yeah... I found 1.8.26 pretty easily. Googling Sacred Plus 1.8.46 returned moslty non-english sites with some 1.8.26 thrown in for :Just_Cuz_21:


I assume I would find Underworld as a seperate download at DLGamer? If I go that way...

Sorry, my bad... Oron is European and I think the Euro English was 1.8.46

You probably do want the 1.8.26. Can't remember the split... think it was US/UK english vs non-US/UK english.

Edited by masteff
Link to comment

Alrighty... thanks, Masteff for the help, but at this point, I've had absolutely no luck I did find a patch for 2.28 at gamershell but I am assuming I need to have Gold/UW installed for it to work, which I cannot find at all. I could order a box version of UW from *wherever* but nothing via download that I could find.


At any rate, the sun is shining outside, and I've been sitting in the Library all day, so I'm gonna go play in the mud ;)

Link to comment

I've got all the patches on my system which I'm uploading but I have teeeeerrible upload speed so it'll be up in about 2-3 hours. I started uploading all the patch languages and it just so happened that the one you need is at the back of the line. Doh! Don't wanna interrupt the process for fear of breaking the uploads actively transferring.

Link to comment

You can run Underworld, with the 2.28 patch on a 64 bit system -- I have been doing so for 2 years. I did nothing special to make it work, at least nothing I can remember.


The most difficult problem to deduce and resolve related to graphics glitches and odd hangs once the game started. I finally found a post on the old SIF that indicated Underworld only runs on a single processor -- so you must set the processor affinity for the executable if you have a multi-core system.

Link to comment

So I have found that I cannot get Sacred Plus (1.8.26) to run on my PC. Schot and I were discussing and he could not get Plus to work either without Underworld installed (and patched up to 2.28).


I did finally get the "driver not loaded, contact Henrik" message after I applied the patch... before applying 1.8.26 it would just say "this application is not designed to run on a 64-bit system".


So I will passively look out for an Underworld (or Gold version if cheap enough) box or download but for now I have given up on Sacred Plus. 8(

Link to comment

essjayehm: You could try this. I haven't personally bought anything from there, but I've only heard positive comments about Good Old Games. There is a heaploads of old classic games. And relatively cheap.

Link to comment

essjayehm: You could try this. I haven't personally bought anything from there, but I've only heard positive comments about Good Old Games. There is a heaploads of old classic games. And relatively cheap.

Cool, Stormwing, thank you!


Just to see if I would've ever found this site (on my own), I googled "Sacred Underworld" (yes, it is a vague description) and I did not see any Good Old Games links within the first 50 pages...


Then, just for lol's, I looked up some prices... Amazon has Underworld for $14.99 :twitch:, and they are also selling Sacred Gold for $7.00 :4rofl:


So, GOG's $10.00 price is just around par for the Gold compilation... and it's a download, not a box that has to ship to *middle-of-nowhere* :)

Link to comment

Alrighty, as promised...


I got Sacred (Underworld) working :yay:


Downloaded Sacred Gold from GOG (kudos to Stormwing for the find - I didn't go for UW only as they were both $10) and installed onto my PC. (I had it on a thumbnail drive, and copied the setup file to my desktop before installing).


I DID NOT JUMP THROUGH ANY HOOPS. I left UAC alone, just clicked yes when it asked if it was OK for "setup.exe to change files on my PC"


I thought I'd have to patch up to 2.28, so I double-clicked the patch, and I got an error "cannot find Sacred" or somesuch...


oh, boy, here we go I thought...


So I double-clicked the shortcut and... the game is running fine! I guess GOG's version is all patched-up, working fine, yada yada, so I will add a :thumbsup: for Good Old Games site (the 3 free games I got for signing up with them may have something to do with my recommendation ;)

Link to comment
  • 1 year later...

Not my style to necro-thread, but here's the 2nd for today. Reason for this one: I need some help. :(


As most of the Vets know, there's a way to set the Default skils of your Sacred ( Plus / Underworld) chars to blancs by adjusting the settings.

I did this in my settings.cfg file, however, it doesn't work.


I'm currently using Windows 7, 64 bit and the game runs without any problems. It's just that the default skills won't change.


What I did was alter the settings.cfg file, found under C:\Program Files(X86)\Ascaron Entertainment\Sacred Underworld, as was described at the SIF.


Because the line: DEFAULT_SKILLS : 1 isn't in the file, I've added it right under the Compat_Video : 1 line, changing the "1" in a "0" (Zero).

I've even changed the security settings so I could adjust and save the file, when opening the file at another time, the added line is there, however the default skills remain. I've even tried DEFAULT_SKILL : 0 because it could be possible I had made a type, yet, to now avail.

This makes me wondering if I made some sort of mistake, as I do remember being able to pick the first two skills myself when using an older computer. So I'm kinda sure it's related to 64-bit OS.

Anyone able to help me out here?



Thorin :)

Link to comment

Well, I'm running on x64 Win7 Ultimate, FWIW. I had an older installation of Sacred Gold, made waaay back. Never re-installed as the game worked. Although I couldn't select the starting skills either. Just checked the congif file and I had changed DEFAULT_SKILL : 0.

Well, just made a fresh install, putting the game on my Windows drive, seeing it's an SSD with enough capacity to store few games. And runs 'em tad bit faster. Patched it all up to 2.28, with the patch from here, changed the line again, same place. And it works. First I thought that maybe there's a separate configuration file somewhere in the own documents or something, but apparently that's not the case.

Dunno if this helps your problem, Thorin, but I though I'd just put up my 10 cents. :)

Link to comment



If you make other changes in the settings file, like turning full screen mode off, does that take effect?


Perhaps do a file search on your pc for settings.cfg and make sure it didn't put another copy of the file somewhere else (which would be really weird, but so is the fact that it's not working for you). My next guess would be the version of the game you downloaded has disabled that feature (which again would be weird).


And not to insult you but... you are testing it by creating a brand new toon and not loading an existing one?

Link to comment

Maybe not quite as 'weird' as you might think.


Windows 7 takes security when it comes to the Program Files folder tree VERY seriously. You could call it almost to an anal retentive level. On the other hand, it's lightyears ahead of the swiss cheese XP came with. I'd rather it be anal than let any old virus attack and infect every single executable on your hard drive.


I've seen some files in that folder NOT be editable... Not until you a.) copy the file elsewhere (such as a C:\temp folder). b.) edit it, then c.) move it back to the original location.


Try that and see if it helps.

Link to comment

@ Masteff: I know I'm getting old and that I'm blont wis blu ise; but I'm not that stupid. (yet) :P

I restarted the game after each attempt, picked a new char, checked the inventory, quit the game when the skills weren't reset to two "new skills" and changed the file again.

I'm aware it was worth a try asking, since it's indeed easily forgotten.

Changing the "Full_Screen" from 1 to 0 (zero) doesn't have any effect either.

The version of the game I use is the one I've been using for ages. I've installed the game from the original CD's, just like I did at my laptop (also using 64bit Win7) and my previous PC.


Now here's the weird thing:

I tried Wolfie's idea (thx for that) by exporting the file, changing it and copying it back.

When I did this at my laptop, the default skills changed into the "pick new skill" line; just as intended.

When doing this at the PC it didn't work.

So I saved the file at a USB-stick, copied it from there into the right folder at the PC .........




and nothing happened. :hysteric:

Next thing I did was checking the rights of the folders at both my PC and laptop. Those were similar, so that can't be the problem.

Since I can play the game, it isn't that much of a problem; it's just making some builds a bit harder.

And since I've been considering buying the Steam Gold-version, I might as well do that, see if the file-change works and open a LAN-game every now and then to mule some good items to my laptop chars in case I'd like to play at that one. (Like: when I'm traveling to/from my parents by train.)


Thorin :)

Link to comment

Weird thing is, it didn't give me any troubles after I reinstalled it in program files. Usually I've kept games outta there for the afforementioned reasons and few others. The old installation was on different hd, no go. New install works like a charm. Looks like it's another little chapter in the weirdness of Sacred- games. :D

And I've completely terminated UAC for that matter. I can handle my comp well without it anyways.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...
Please Sign In or Sign Up