Jump to content


Photo

Back again


  • Please log in to reply
3 replies to this topic

#1 GreenMagic469

GreenMagic469

    Indium Shaman

  • Members
  • 18 posts
  • Real Name:Matt
  • Platform:XBOX
  • Gamertag:GreenMagic469

Posted 08 November 2014 - 11:11 AM

Hey guys, I'm sure none of you remember me, I've been a lurker for awhile, but I've had an account or two on here before. I've forgotten my log in information both times, after giving the game a hiatus for awhile, but now that I'm playing hardcore again I figured I should make a new account. Glad to see the forum is still active and there are still people enjoying Sacred 2! Hopefully some of you 360 owners will wanna team up and play sometime. See you around the forum!

#2 gogoblender

gogoblender

    Dark Sun Guardian

  • Administrator
  • 32,201 posts
  • Location:Montreal,Quebec, Canada
  • Real Name:Rommel
  • Platform:PC

Posted 08 November 2014 - 12:08 PM

Good seeing you back greenmagic!

Do you remember any old nics you used to use here at DarkMatters?

I can probably help with finding the old account

Did you ever make posts or posts?

 

:)

 

gogo



#3 GreenMagic469

GreenMagic469

    Indium Shaman

  • Members
  • 18 posts
  • Real Name:Matt
  • Platform:XBOX
  • Gamertag:GreenMagic469

Posted 08 November 2014 - 12:19 PM

I think I might have had an account called MWright469 or something similar at one point. Don't remember honestly, it's probably been over a year since I came to the board. I do remember you however, you and some other members gave me some great advice about not getting the blacksmith skill on the console versions and other minor things I would have missed were it not for the help. Came back to learn even more about my favorite RPG!

 

Oh, as a side note, is the site experiencing any issues right now? Most of the forum is white and I see no layout or anything, not sure if its just my computer or the forum.


Edited by GreenMagic469, 08 November 2014 - 12:21 PM.


#4 gogoblender

gogoblender

    Dark Sun Guardian

  • Administrator
  • 32,201 posts
  • Location:Montreal,Quebec, Canada
  • Real Name:Rommel
  • Platform:PC

Posted 08 November 2014 - 06:11 PM

 
Oh, as a side note, is the site experiencing any issues right now? Most of the forum is white and I see no layout or anything, not sure if its just my computer or the forum.


It's up pretty regularly for me me now and I just checked from iPad and PCs



Gogo




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users