Jump to content

Sacred 2 on Linux (Lubuntu 22.04 LTS) help running?

Recommended Posts

So I got a new computer. I really, really hate windows. Windows is like meth, I don't want to use it, but I don't have much choice since nothing else works.

18.04 was my last try, and I just gave up and used dual-boot back then. Windows 7 ran Sacred 2 quite perfectly, occasional crashes, but rare enough to not be an issue.

So now I can install Sacred 2 Gold just fine. There's been a few errors during installation, I think? but same happened with Sacred UW. Sacred 1 just works fine, I didn't exactly play much yet, but I guess I'll play it for now since Sacred 2 is not working.

I've tried just about everything. Winetricks, Wine 6, Wine8, Lutris GEs, various other Lutris versions, etc. If I run in desktop mode + fullscreen in Lutris, the game just hangs on launching. All other methods lead to one tiny error:

00ec:err:sync:RtlLeaveCriticalSection section 00D4B874 "?" is not acquired

Nowhere on the internet does it say what the issue is. WIth Sacred UW I got a whole laundry list of errors, put PlayVideo=0 (since the issue was the video) and it runs fine. Wine or lutris don't spit out any useable info  with Sacred 2 for a total Linux newbie.

Tried 64 bit, 32 bit, no PhysX, PhysX redist, PhysX winetricks, DirectX9 redist (I know this is bad now, but I did it and all other things tested on clean wineprefixes), Vulcan DX9, winetrick DX9, Fullscreen, windowed, 16 bit color, etc.

Do I just give up? Are there other things I can try? I mean, can I learn how to resolve these kinds of issues? Wine and Lubuntu are way better than when I last tried it (tons of stuff didn't work well), but now all my go-to apps work just fine, only problem is I want Sacred 2 :(

My guess is it's associated with Windowed mode or not, DX9/PhysX and/or color depth. Just tried running as many native settings as possible but no go. I saw Chattius got it to work, so there must be a way? If it worked for nobody I wouldn't even have tried, but so many people run it just fine.

Played Sacred UW all day with no issues. Runs way smoother than on windows, but that might be due to better system specs + SSD HD. The game has basicly no load times or lag.

Edited by Shinryuu
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...
Please Sign In or Sign Up