Jump to content

An exception has occured!


Recommended Posts

So, I'm brand new to Sacred 2 and getting a little frustrated.  I keep getting some exception error/crash not too long after starting:

       An exception error has occured!

       Error #: 1

       Function: ParticleSystemManager::createSystem

       Description: template not found'x_stone_streak'.

       File: .\Graphics\particle\particleSystemMgr.cpp

       Line: 199

**I DL'd from Steam (ver 2.65.2) and have the following mods: Trimmed Elite Textures pack (added to install folder), CM 1.60 & hotfix (added/overwritten regular install), Scared 2 Enhanced Edition (GME MOD folder), and Reduced Fog (GME MOD folder).


The template not found has also been 'gen_missle_3x' (or something close to that).  I tried reinstalling the game and turning off the mods I have included through GME, but continue to get the error.  I can start the game and kill a few things, but at some point, the game crashes with this error.  The only thing I've not tried is the game in the original state without the Trimmed Elite Textures pack and CM 1.60.  Has anyone ran into this problem and knows a fix?


Comp: Windows 10, 6700k, 1080Ti (have PhysX turned on)


Thanks for any help/guidance ahead of time!

Edited by Xain
Posted topic accidentally without details...
Link to comment

These are the files that match your error, couldn't be sure on which "missile 3" you needed so I uploaded both. Navigate to "drive letter:\***\Steam\steamapps\common\Sacred 2 Gold\scripts\particle" and place the missing files there, as according to that error they should be missing. If Windows asks you to overwrite try doing so after creating backups of the original and see if the exception still occurs.




That error sounds like something went wrong during the installation of one the additional components, or it could be that one of the mods isn't compatible with the rest (I'm looking at the Reduced Fog mod to be honest since the rest is by now fully compatible). By the way, did you download the more recent version of Enhanced Edition or are you using the old one?

  • Thanks! 1
Link to comment

I believe I have the most recent Enhanced Edition (Dec 2017) installed.  I've not had an "exception" error since adding the missing particles (stone_streak and gen_missile3), so this appears to have worked. 

Now I'm just randomly crashing here and there without an error .  The game will just exit with no pop-up or anything.  This is with Enhanced Edition (enhanced spells), Reduced Fog, Trimmed Elite Textures, and CM 1.6/hotifx all installed/turned on.  It happens maybe once an hour on average, so much better than the exception at least.  I may experiment with Reduced Fog turned off next time.

Thanks for the help and quick response!

Link to comment

Glad it worked, but it still shouldn't be crashing like that... :( Could you post the crash reports from the Windows Event Viewer please? It often says where the problem is. If they all say the same post just one.

  • Thanks! 1
Link to comment

I found a fix for this that seems to have worked: File Explorer > View > Options > Change Folder and search options > Privacy >Clear File Explorer History


All the entries are the same other than some hash values.  Here is what I'm seeing:

Application Error:

Faulting application name: sacred2.exe, version:, time stamp: 0x4be45a9b
Faulting module name: ntdll.dll, version: 10.0.17134.1, time stamp: 0xc8733c73
Exception code: 0xc0000005
Fault offset: 0x00091829
Faulting process id: 0xe28
Faulting application start time: 0x01d3f19e3109a0cf
Faulting application path: D:\Steam\steamapps\common\Sacred 2 Gold\system\sacred2.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 5be227b7-9933-4ec1-82be-5ebd97a348c6
Faulting package full name: 
Faulting package-relative application ID:

Windows Error Reporting Info:

Fault bucket 1915561203566166100, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: sacred2.exe
P3: 4be45a9b
P4: ntdll.dll
P5: 10.0.17134.1
P6: c8733c73
P7: c0000005
P8: 00091829

Attached files:

These files may be available here:

Analysis symbol: 
Rechecking for solution: 0
Report Id: 5be227b7-9933-4ec1-82be-5ebd97a348c6
Report Status: 268435456
Hashed bucket: 583bf5462867cb789a9570c3fc14c054
Cab Guid: 0

Edited by Xain
Problem fixed
Link to comment

So, I've ran into a couple more exception errors due to missing particles, just like before.  I tried a fresh install from Steam and noticed that there are no "x_" particles, only "fx_".  Is there any way you can package all of the "x_" particles in a zip file?  I thought about just copying all the "fx_" particles and renaming them to "x_", but there are a couple of different values between the two (with the couple I compared) and I' not sure how the game would handle that.  Plus, there are over 800 of the files, which would be a rather tedious.

I have no idea why this is the way it is, but I'm guessing the Steam version has no "x_" particle files since this has happened four times with the Steam install now.

Thanks again!

Edited by Xain
Link to comment

There's nothing wrong with the Steam version nor any missing files, as I've been using it myself and never had these issues. A ntdll error is a problematic issue though, and it may be the indirect cause of your problems with the game since it's a system error. You should try fixing your system first and then see if your game still crashes, everything else is just throwing the dust under the carpet until it all blows up on your face.

Depending on how old you Windows installation is you should think about reinstalling it, if it's recent then run the recovery tool from Windows's disc/image to try and repair the system, if you HDD is old it may be getting faulty and corrupting files, you may have a virus that's tampering with your system, etc. Try some troubleshooting because I can guarantee you that Sacred 2 shouldn't be causing ntdll errors, like at all!

Link to comment

I didn't have anymore of the ntdll errors after clearing my File Explorer history (found it as a suggestion in some MS forums for the ntdll error).  I just happened to run into the exception with a template not found again.  This time it was with x_gen_missile2 (which I fixed by just adding missile3 again and renaming) and one of the fireballs.  So, I decided to try a clean install again.  When I looked in my particle folder after the clean install (without adding CM patch, Trimmed Elite, or anything else), there were zero "x_" files, only "fx_".  Since adding the specific "x_" files worked before (like the ones you provided), I was simply assuming that there may be "x_" file for every "fx_" file in the particle folder, which I appear to be missing.

Link to comment

Yeah, but the CM Patch adds particle files because some were changed with it, namely magic staff projectiles. I'm counting them on my folder and there are 16 particle files with modify dates different from the install date of the game, which means that they were added later by the CM Patch, and all of them are x_something or fx_something.

Do you still run into exceptions even with the vanilla game (without anything else installed on top of it)? Because that really shouldn't happen as well. I was thinking that maybe something went wrong during the patch installation and that some files weren't properly placed or something like that, but now I'm a bit confused as to what it could be. And if you did a clean install of the game, I mean, it should be working!

Anyway, with CM Patch 1.60 I have 843 files in my particle folder, and like I said 16 of those with modify dates dating from 16/10/2017 to 25/11/2017. You can cross-check with your install if you want to.

Link to comment

I added CM 1.60 + hotfix back and still didn't have any x_something particle files, just fx_something (837 of them).  I added the two you gave me and have since added two more, which are just renamed fx_something files matching whatever x_something I've gotten an exception error for again.  I don't get the exception again with adding a renamed fx_something file.  I have no idea what the problem is man, but I've checked the vanilla install and CM patch and haven't seen any x_something particle files under \scripts\particle anywhere.  Are they created while playing or something?

I have not tried just playing vanilla alone since I only have characters created with the CM patches.  Since adding the renamed fx_something particles files seems to be working, I'll just continue doing that for the time being.

I'm using CM 1.60, CM 1.60 Hotfix, and Trimmed Elite Textures from this post: 


Link to comment

Wait, you're using the Addendum+Hotfix without installing the CM Patch 1.60? Well if so that right there is the cause of your issues. You need to install the Addendum on top of CM Patch 1.60! That's why you don't have those files man, they're installed by the CM Patch 1.60 in the first place!

Here's what you're going to do to get things in order:

  • Do a clean reinstall of the game
  • Install CM Patch 1.60 from this link: 
  • Copy Trimmed Elite Textures into the PAK folder: https://drive.google.com/open?id=0B5yMxfzmPZ4_R2J2eFZxc2wzeGc
  • Play the game, you shouldn't have any exceptions like you've found so far
  • Only then will you use the Addendum+Hotfix so you can enjoy Dimitrius' mod


I'll be damned if this doesn't solve your issues! :D


Edited by Androdion
  • Thanks! 1
Link to comment

Hrm, I had read that I needed to instal the Addendum on top of the CM 1.60 patch, but looking at the thread and seeing it labeled as a hotfix, I was thinking it was the same as the Addendum hotfix.  Perhaps this will fix all my problems!  Reading comprehension apparently escaped me, haha.  Thanks for all the help man!

Link to comment

No problem. ;)

By the way, your confusion lies with the "hotfix" word since CM Patch 1.60 was released on December and given a "hotfix" a week later but it has stayed like that ever since, whereas the Addendum has a "hotfix" which is being updated as reports are taken cared of. Hope that clears the air. :)

Link to comment

I've played a couple hours now with everything installed and have run into no issues thus far.  The x_something files I was missing are now there, so that was all errors with not having the base CM 1.60 patch installed.  It also explains why I had some weapons/armor with no graphics as everything is now visible.  Took a bit of troubleshooting, but all appears to be well!

Edited by Xain
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...
Please Sign In or Sign Up