Jump to content

Recommended Posts

Hi all.

So I just grabbed Sacred Gold from GOG and by itself it runs just fine. Whenever I try to incorporate DGvoodoo however I just immediately get the generic Windows box saying 'Sacred has stopped working'. Like it won't even begin to boot up. Seems to be something about the DLLs, since as soon as I add them to the game directory it does this. I've checked everything I can think of.

Off the top of my head this is what I've tried.

  • Double checked my DirectX version (it is 11 so that should be fine).
  • Tried older versions of DGvoodoo and also the current debug version. This is literally all it says before crashing.
  • Checked firewalls and such are off.
  • Tried MANY different setup combinations, compatibility modes etc.

I'm ready to give up but just in case thought I'd post. All I really wanted from Voodoo was the widescreen.

Link to comment

You can either go for Sacred NL, which offers HD support without rebalance, or for Sacred Reborn, which offers HD too, but has also a wide spectrum of bug fixies, rebalanced enemies, new systems and items. It is a bit rougher for newbies though, especially when you stumble into certain caves. :)

Reborn Mod:
Sacred NL:

  • Thanks! 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...
Please Sign In or Sign Up