Jump to content
Baaleos

Sacred LAN Gameservers available

Recommended Posts

Baaleos    0

Sacred VPN Lan Games Available

Download Wippien (open source vpn client)

Install,

Create an Account

 

Go to Add Contact,

add SacredOpen@wippien.com

Presto!

 

Next time you go into Sacred Underworld, check the Local Network games section, and you should see 5 Free Play Game Servers (one for each difficulty band).

 

The Servers are monitored by a Process Watchdog, will be restarted within 10 seconds etc if they ever crash, and the server content itself reboots when all players leave the server.

 

Servers will be up 24/7 for anyone to play on them.

So far, got about 5 players registered on the vpn.

 

Servers are hosted in England in a Datacenter, of course ping will depend on your location in relation to the datacenter.

Edited by Baaleos

Share this post


Link to post
Share on other sites
Dragon Brother    400

Thats cool. Been a while since I played Underworld. Don't know if I should be installing another game now that its uni time though...

Share this post


Link to post
Share on other sites
Knuckles    846

I know several people still play Underworld and this has to be a nice present to be able to play on-line again - finally. Sure we'll have members trying this out. Thank you for posting all the details

 

p.s. welcome to the forums :D

Share this post


Link to post
Share on other sites
Baaleos    0

I know several people still play Underworld and this has to be a nice present to be able to play on-line again - finally. Sure we'll have members trying this out. Thank you for posting all the details

 

p.s. welcome to the forums :D

 

 

This is just incase anyone has any problems seeing the servers via Local Network connection (LAN Via Wippien)

 

 

Try the following.

 

 

 

When Wippien is open,

 

Click on Settings,

 

Go To Network,

 

Set the Network Settings to be

 

Gateway = 5.0.0.1 (ticked)

 

IP Address = 5.3.154.x (x can be your own number 1-254)

 

Netmask = 255.0.0.0

 

 

 

Also set the Radio Button to Obtain from IP Provider Database.

 

And fill in the edit box with the following information

 

http://www.wippien.com/ip/?jid=xxxx

 

 

 

Where xxxx = your wippien address eg - Baaleos@wippien.com

 

The IP Provider allows the wippien servers to manage the ip allocation.

 

 

 

 

 

 

 

Once you are sure you have all these settings set, try right clicking on SacredOpen in wippien, and try to ping.

 

If the ping succeeds, there is a good chance the Sacred Servers will show up.

 

 

 

If not, then check your windows firewall, or third party firewall. You must allow Wippien access to the outside world, as well as sacred.

Share this post


Link to post
Share on other sites
Baaleos    0

Note - I just did an experiment - I was still able to see the servers when my Home Computer was set to 5.3.153.x and the server was on 5.3.154.x

 

Its possible we only need to worry about the 5.3.x.x part.

 

After changing the ip address, you must restart wippien.

Share this post


Link to post
Share on other sites
gogoblender    1,465

Thanks Baaleos for bring this topic over to FDM. It's a good resource you are offering for players.

 

Welcome to DarkMatters!

 

:)

 

gogo

Share this post


Link to post
Share on other sites
Baaleos    0

Got about 9 players subscribed to the servers now.

 

I'm also developing a new project that will allow other people to host servers and have them connected together.

 

Eg 10 physical machines with gameservers, they are automatically added to you're Wippien, and voila, 10 physical machine worths of gameservers available to the public.

Share this post


Link to post
Share on other sites
gadenh    0

I want to ask why the progress isn't save for the missions :? btw these servers are great I've been searching for such thing for a long time thanks

Share this post


Link to post
Share on other sites
Baaleos    0

Its just a guess,

But I think it might be cause the games are set to 'Free Mode'

 

Which may mean that the quests reset.

Share this post


Link to post
Share on other sites
gadenh    0

Could you make one campaign server for the original campaigns ?

Share this post


Link to post
Share on other sites
Baaleos    0

I've added an extra 5 gameservers for sacred classic campaign.

 

Will try to get round to adding another 10 for underworld campaign and pvp

Share this post


Link to post
Share on other sites
stubbie    18

Please excuse my ignorance with matters when it comes to servers and such, but are any of these servers hardcore? :unsure:

Share this post


Link to post
Share on other sites
Dobster    35

Has anybody managed to get this working with win7 64 bit? doing a bit of reading about Wippien, it seems it doesn't work with it. That would explain why I can't connect :(

Share this post


Link to post
Share on other sites
Baaleos    0

I've added a game server for each gameplay type at each difficulty. All 20 of them are showing now for me and another player who was testing them out for me.

 

I'm unsure why Dob n llama8 are having problems connecting, it seems to b a Wippien problem specific to them. :-(

Share this post


Link to post
Share on other sites
Baaleos    0

@ stubble

These game servers do not allow for hardcore mode, as the characters are stored on you're own pc.

Share this post


Link to post
Share on other sites
Dobster    35

Llama is on XP so it must be some other issue.

 

All we get is the message "VPN not established yet"

 

Thanks so much for setting this up Baaleos, hopefully we can figure out whats going wrong.

Share this post


Link to post
Share on other sites
Baaleos    0

@ Dobster

Are you on a 64bit operating system?

 

That includes XP64 Bit.

 

 

If so, you too will need to use the special instlal instructions to get the wippien adapter/ip address working.

 

Anyone having connection problems, please post the following.

 

1. Operating System

2. Are you running Wippien as admin etc

3. Behind a router?

4. If behind a router, are you set up as far as port forwarding and dmz goes?

 

 

Note for router users.

Although I dont have any problems with routers and wippien not working together, it may be necessary to set your gaming pc to be on a dmz or to set up portforwarding for port 5222 (wippien login port)

Edited by Baaleos

Share this post


Link to post
Share on other sites
Baaleos    0

Note

Dobster and I have been working at this for a while, and narrowed his problem down to what appears to be his Service Provider.

 

He can ping the server, but the server is unable to ping him, which I believe is stopping him from receiving the server list/response.

 

If anyone has any problems, please post

 

1.Operating System (32bit or 64bit)

2. Service Provider

3. Type of Router

Share this post


Link to post
Share on other sites
Baaleos    0

Note

Dobster and I have been working at this for a while, and narrowed his problem down to what appears to be his Service Provider.

 

He can ping the server, but the server is unable to ping him, which I believe is stopping him from receiving the server list/response.

 

If anyone has any problems, please post

 

1.Operating System (32bit or 64bit)

2. Service Provider

3. Type of Router

 

 

The 64Bit Driver seems to have resolved Llama8's problem.

He is now ingame.

Share this post


Link to post
Share on other sites
Baaleos    0

For anyone interested

 

The required/Suggested version to join these servers is v2.28

 

 

Just in case anyone tries to join, and get a 'Wrong Version' error.

Share this post


Link to post
Share on other sites
Baaleos    0

For anyone on Windows 7 and are having problems seeing the game servers.

 

There is a known issue with windows 7, where it keeps network data from different networks, segregated etc.

 

to fix this, you need to do the following.

 

 

Run regedit

Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}

Underneath you should see several keys labeled 0000, 0001, 0002 etc… Look through these and find the VMware adapters. They will probably be near the end of the list if you just installed VMware.

For each of the VWware adapters, add a new DWORD value named “*NdisDeviceType” and set it to 1 (make sure you get the * at the beginning of the name, I missed that the first time).

Disable and Enable each of the network adapters.

That should take care of the problem. Setting *NdisDeviceType to 1 causes Windows to ignore the device when it does network identification. Here is an MSDN article with more details.

 

Taken from

http://robboek.com/2008/12/18/vmware-unidentified-network-issue-in-vista-and-windows-server-2008-fix/

 

more info here

http://toastedcheesenips.blogspot.com/2010/12/merry-christmas-here-have-wippien-x64.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×