Jump to content

1 Screenshot

About This File

Somewhere in the world of Ancaria there is a priest who was destined to serve Gods in a remote location. He stays in his half-forgotten temple and rarely sees people except for hunters and travelling merchants who stop once in a while to make offerings to the Gods. This priest spends his free time breeding and training exotic creatures. Those rare times when he goes out of the temple, his pets usually follow him. He thinks that animals make good companions to lone travelers like him... and like you.

 

This mod adds new special mounts for all 7 characters. They can be purchased from a new special mount dealer deep in the Jungle. Detailed information on all the variations in mount appearance and stats can be read about in this thread on DarkMatters forums. Each character gets 4 new special mounts, with the exception of the High Elf, who gets 7 new mounts.

 

This mod requires the Ice and Blood expansion (or Sacred 2 Gold) and the latest Community Patch (1.50) to be installed beforehand. The CM Items Mod (optional) should be installed after the Community Patch but before anything else.

 

Supported languages: English, French, German, Polish, Russian, and Spanish (Spanish requires download of an additional language patch).

 

Installation (with no other mods installed):

  • Download the Jonesoft Generic Mod Enabler (GME) and install it to your Sacred 2 root folder (the main folder where Sacred 2 is installed). Mod Enabler is available HERE
  • After running the GME once, it will make a folder called "MODS" there.
  • Extract the contents of the rar file and copy the "Elite Mounts v1.10" folder into the "MODS" folder.
  • Run the GME and enable Elite Mounts v1.10. It may take a moment to install. The GME will back up your clean files and will allow to you to easily enable/disable the mod as you wish.

The mod also comes with compatibility patches for some of the more popular Sacred 2 mods. Use the Generic Mod Enabler to activate them in the order described below.

 

Installation order if using other mods:

  1. Elite Mounts Mod
  2. Wardust's Serious Textures Mod (must be version from Sacred 2 Nexus) (ignore compatibility patch)
  3. Enhanced Spells Mod (+ optional Challenge Mode) or Survival Mod or Llama's CM Patch Mod (choose one, these three mods are not compatible with each other)
  4. Compatibility Patch for whichever mod you chose to install at step #3 (Llama Mod or Survival Mod ONLY, Enhanced Spells 1.3+ has built-in compatibility so no patch necessary).

 

This mod is NOT compatible with:

  • Sacred 2 Nude Mod 2016 (compatibility patch is available with the Nude Mod)
  • Diablo 2 Fallen (mounts are already integrated)
  • Any older mod not updated for CM Patch 1.50

 

This mod should work just fine with Fleet's Nude Skins, Reduced Fog, Przemba's Visual Mods, and any music/sound mod.


What's New in Version   See changelog

Released

No changelog available for this version.




User Feedback

Recommended Comments

If you get Wardust's Textures from the Nexus HERE then you don't need to worry about the compatibility patch. The install order is: Elite Mounts first, then Wardust's Serious Textures, then proceed as normal.

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×