Jump to content
Countdown To Christmas!
 

From the Sacred 2 Christmas Island Soundtrack
Click to Open Player!
 
Whisky

An ANNOYING glitch with Sacred gold steam version

Recommended Posts

Hay guys, my brother and I got sacred gold for steam not to long ago and we have encountered a weird glitch. When starting up the game, 9 times out of 10 the game will freeze when loading the fonts. We have more modern windows 10 laptops and we have no idea what causes this glitch. Also when loading the disc version on our old windows 7 laptops, the glitch has never happened. Any ideas?

 

-Whisky

Share this post


Link to post
Share on other sites

It seems that many who are running (trying to run) Steam versions of Sacred 2 Gold are having some startup issues. I'm linking a thread below that helps (I hope) troubleshoot the problem of the game not loading. Please be sure to check the links to the topic in the Steam fora as well.

 

 

Share this post


Link to post
Share on other sites
13 minutes ago, Hooyaah said:

It seems that many who are running (trying to run) Steam versions of Sacred 2 Gold are having some startup issues. I'm linking a thread below that helps (I hope) troubleshoot the problem of the game not loading. Please be sure to check the links to the topic in the Steam fora as well.

 

 

thanks for the heads up about sacred 2 but I was referring to sacred 1 gold. Sacred 1 will start up and go though the dev screens and get to the loading bar screen but it will freeze 9/10 times when it states that it's loading fonts.

Share this post


Link to post
Share on other sites

You may want to check the Steam fora for discussions related to your issue. Hopefully, you will find a solution there.

  • Thanks 1

Share this post


Link to post
Share on other sites

I used to have this issue occasionally with older cards. I have 4 solutions

- Restart PC and start it like that.
- Enter Config and enable 32bit. Disable video compability mode and disable "Windows compatibility" of any kind.
- Open config settings in MyDocuments folder or Sacred folder (where the saves are located) and edit Settings.cfg. Change the following if they are represented by zeroes :

FONTAA : 1
FONTFILTER : 1
FONTPAGES : 1
GFX : 1
LANGUAGE : US


- Reinstall the game altogether and check the Steam file integrity. Install the game strictly into C: partition. 

All of the above might or might not solve the issue. Of course one of the easiest solutions is to simply run the game in the Windowed mode. 
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Basically don't touch anything, while it starts up or it will freeze. Don't click on anything, don't minimize steam until you see the main screen. The Steam overlay will also freeze Sacred for the time it's displayed.

Edited by Thorium

Share this post


Link to post
Share on other sites

You can patch it to unofficial 2.29, to get rid of the steam overlay freezes. You still need to set it to 32bit in config.exe to get it to not freeze on startup.

To patch the Steam version of Sacred Gold to 2.29, just extract the .exe from this zip into your Sacred folder and use it to start the game instead of starting it over Steam. Example path to the Sacred Gold installation: "C:\Program Files (x86)\Steam\steamapps\common\Sacred Gold"

Share this post


Link to post
Share on other sites

There is an easy fix for this problem...go into your Program filesx86, steam folder, steam apps, common, Sacred gold, config, and change your color settings to 32 bit.  All should be fine after that.  I saw it posted here, but I figured I would post the path to get there.  It should be all you need to do.  I am running win10 64 bit pro, GTX1060, and ssd's in raid mirror.  Game starts so fast it goes straight to log-in.  Runs great for me, no issues other than game bugs which I am going to post a video of one that keeps happening to me.  Pretty comical!

  • Thanks 1

Share this post


Link to post
Share on other sites

Downloading and installing the newest community patch has fixed that for me... so far. I have had a different problem than you guys, but also running it on Windows 10, and bought it on steam

  • Like 1

Share this post


Link to post
Share on other sites
On 9-5-2018 at 11:17 PM, tipsterdad said:

There is an easy fix for this problem...go into your Program filesx86, steam folder, steam apps, common, Sacred gold, config, and change your color settings to 32 bit.  All should be fine after that.  I saw it posted here, but I figured I would post the path to get there.  It should be all you need to do.  I am running win10 64 bit pro, GTX1060, and ssd's in raid mirror.  Game starts so fast it goes straight to log-in.  Runs great for me, no issues other than game bugs which I am going to post a video of one that keeps happening to me.  Pretty comical!

THIS!!! Has made my life so much better. :)

 

I usually was playing Sacred: UW / Gold at my laptop when visiting my parents. And usually that game started or froze; there simply was no other option. And the latter happened a lot more as the first, occasionally making my gaming experience a hell. Having the same problem at my PC, I didn't even care to hope to play this game again. However.............

I changed the settings today, tried to launch a game at my PC and it ran flawlessly. In fact, it seemed the black bars at the side were even a bit smaller as they used to be before upgrading my system to Win10. I've been running around a bit in Ancaria, playing a Dwarf of which all of you might guess the name :D  and the game ran without any problems. Looks like I've got some very long nights ahead of me in the future as well as the certainty that I'm able to play this game when visiting my parents, when we're trying to enjoy our various computer games.

 

Thorin :)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now