Jump to content

Sacred Underworld - Help with Lan network issue


Recommended Posts

I'm trying to start a Lan coop campain (alone I just need it to dupe items) but after I've chosen the PG and I start the game it blocks on "testing ports" for like 10 sec and then it says "init failed"

I tried steam file repair
I tried unistalling and reinstalling
I tried port forwarding manually my router 

none of these worked, it's not about the dupe, the big problem is that I was planning to play Lan with my friends later on 

 

please tell me if anyone had experienced this issue or has any solution. thanks.

 

edit: it was a problem with my modem and firewall, solved it by manual port forwarding

 

Edited by Arendiv
solved
  • Like! 1
Link to comment
  • gogoblender changed the title to Sacred Underworld - Help with Lan network issue
35 minutes ago, Arendiv said:

I'm trying to start a Lan coop campain (alone I just need it to dupe items) but after I've chosen the PG and I start the game it blocks on "testing ports" for like 10 sec and then it says "init failed"

I tried steam file repair
I tried unistalling and reinstalling
I tried port forwarding manually my router 

none of these worked, it's not about the dupe, the big problem is that I was planning to play Lan with my friends later on 

 

please tell me if anyone had experienced this issue or has any solution. thanks.

Hi Arendiv and welcome to the forums!

There's actually (I think ) some good threads on multiplayer these days around here somewhere and I remember getting it to run successfully with Schot... Radmin maybe or some other work around..im booting off to work though so dont have much time here, but we also have some players here who are playing Underworld everyday

@xInquisitor1961x @SupremeJoker

 

maybe them or some others here who have actually done mods with the game  can help you out.

Enjoy da Underworld

:cow:

gogo

 

  • Appreciation 1
Link to comment
Posted (edited)
36 minutes ago, Dax said:

 

Reborn mod works too.

 

-Open config, unselect "full screen"

-Run Sacred Reborn GameServer, select difficulty. Check "Wolfes Lair" for the right levels

-Run Sacred Reborn

-Pick Multiplayer + LAN

-Klick "Join", then "Start"

-Go back to desktop

-Run Sacred Reborn again and repeat the procedure. You can swap items freely then between characters.

I tried following the video but it still doesnt work

is there anything else I could do before modding?

(also I dont think modding would help since the problem isnt finding a server but starting the lan mode)

Edited by Arendiv
Link to comment
21 minutes ago, Dax said:

Check here.

https://sacredonlinecommunity.forumfree.it/?f=10777642

The user Tur0k wrote a Radmin VPN tutorial some years ago, but I think the situation is a bit difficult right now. You know world politics and bla.

Thanks Dax!
on coffee break now woot!
did a search and found this guide  that Schot   made the last time we went  to document our lan playing sacred underworld gold

I will see about pinning it in a more accessible place here for more players to use as we’re seeing more players playing underworld again with all the mods

 

Link to comment
On 8/9/2022 at 7:14 AM, Arendiv said:

I'm trying to start a Lan coop campain (alone I just need it to dupe items) but after I've chosen the PG and I start the game it blocks on "testing ports" for like 10 sec and then it says "init failed"

I tried steam file repair
I tried unistalling and reinstalling
I tried port forwarding manually my router 

none of these worked, it's not about the dupe, the big problem is that I was planning to play Lan with my friends later on 

 

please tell me if anyone had experienced this issue or has any solution. thanks.

 

edit: it was a problem with my modem and firewall, solved it by manual port forwarding

 

Hi Arendiv!

How did it go? I just had a chance to notice how looooooooooooong lol that link I gave you on. This game...dang, its buggy right? I hope you were able to get in, and if you could share your way? Maybe I can edit out a bunch of pages and make a more contemporary way for sacred underworld mp players that works easily

And if you're hooting it up in Ancaria cuz you found a goblin cave with a cauldron full of good orc brew and wont be back for a few days

thats okay too

:drunkards:

gogo

Link to comment

I had to go on my router website and open 2005 and 2006 ports, while trying everything I got here, so enabling data flow for modem and disabling full screen.
downloaded radmin (I dont trust hamachi anymore) and followed a guide here on radmin (I dont remember which one).

I dont know what did the trick exactly but the problem seems to be gone, I can see and log in the public servers on radmin

 

thx for the help everyone!

Link to comment
23 minutes ago, Arendiv said:

I had to go on my router website and open 2005 and 2006 ports, while trying everything I got here, so enabling data flow for modem and disabling full screen.
downloaded radmin (I dont trust hamachi anymore) and followed a guide here on radmin (I dont remember which one).

I dont know what did the trick exactly but the problem seems to be gone, I can see and log in the public servers on radmin

 

thx for the help everyone!

Yeah Schot found radmin very effective  ! I was surprised how easy it was to create a lan for us. Thank you for answering back!

:JC_hurrah:
I will merge your topic with shots topic to keep the information together

I’m super happy you found our little community have an amazing day keep loving sacred!

:hugs:
gogo

  • Thanks! 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...
Please Sign In or Sign Up